summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-04-29 20:08:58 +0200
committerKarel Kočí <cynerd@email.cz>2017-04-29 20:18:10 +0200
commite17beb5c2327a1764069d28a424d489022bc29d1 (patch)
tree3706f997fb533a3bc65400dc1c670ff443d7000e /sys-boot
parentff32725fff6b3bd40a87f0b21152764084f9d33a (diff)
downloadgentoo-personal-overlay-e17beb5c2327a1764069d28a424d489022bc29d1.tar.gz
gentoo-personal-overlay-e17beb5c2327a1764069d28a424d489022bc29d1.tar.bz2
gentoo-personal-overlay-e17beb5c2327a1764069d28a424d489022bc29d1.zip
Linux configuration updates
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/linux/files/configs/base14
-rw-r--r--sys-boot/linux/files/configs/desktop5
-rw-r--r--sys-boot/linux/files/configs/kvm6
-rw-r--r--sys-boot/linux/linux-4.10.13.ebuild3
4 files changed, 28 insertions, 0 deletions
diff --git a/sys-boot/linux/files/configs/base b/sys-boot/linux/files/configs/base
index 092fb87..bfb570a 100644
--- a/sys-boot/linux/files/configs/base
+++ b/sys-boot/linux/files/configs/base
@@ -34,3 +34,17 @@ CONFIG_NLS_CODEPAGE_852=m
CONFIG_NLS_CODEPAGE_850=m
CONFIG_NLS_CODEPAGE_1250=m
CONFIG_NLS_ISO8859_2=m
+
+# Recovery from HW memory failures
+CONFIG_MEMORY_FAILURE=y
+CONFIG_HWPOISON_INJECT=m
+# Memory placement aware NUMA scheduler
+CONFIG_NUMA_BALANCING=y
+
+# I don't use selinux
+CONFIG_SECURITY_SELINUX=n
+# Scrollback buffer size
+CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=1024
+
+# Framebuffer
+CONFIG_FB_VESA=y
diff --git a/sys-boot/linux/files/configs/desktop b/sys-boot/linux/files/configs/desktop
index fb749e7..5dc6c7e 100644
--- a/sys-boot/linux/files/configs/desktop
+++ b/sys-boot/linux/files/configs/desktop
@@ -36,8 +36,13 @@ CONFIG_VFIO_MDEV_DEVICE=m
# LCD control
CONFIG_LCD_CLASS_DEVICE=m
CONFIG_LCD_PLATFORM=m
+# EDID data in /lib/firmware
+CONFIG_DRM_LOAD_EDID_FIRMWARE=y
# Faster bootup using async. SCSI probe
CONFIG_SCSI_SCAN_ASYNC=y
# AHCI SATA platform support
CONFIG_SATA_AHCI_PLATFORM=y
+
+# Switchable graphics
+CONFIG_VGA_SWITCHEROO=y
diff --git a/sys-boot/linux/files/configs/kvm b/sys-boot/linux/files/configs/kvm
index 4158e3b..4ee8445 100644
--- a/sys-boot/linux/files/configs/kvm
+++ b/sys-boot/linux/files/configs/kvm
@@ -13,3 +13,9 @@ CONFIG_VIRTIO_PCI=m
CONFIG_VIRTIO_BALLOON=m
CONFIG_VIRTIO_INPUT=m
CONFIG_VIRTIO_MMIO=m
+
+# Memory page merging
+CONFIG_KSM=y
+
+# Virtual GPU
+CONFIG_DRM_VIRTIO_GPU=m
diff --git a/sys-boot/linux/linux-4.10.13.ebuild b/sys-boot/linux/linux-4.10.13.ebuild
index b37508c..a05ff34 100644
--- a/sys-boot/linux/linux-4.10.13.ebuild
+++ b/sys-boot/linux/linux-4.10.13.ebuild
@@ -11,6 +11,7 @@ S="${WORKDIR}/linux-stable-${PV}"
LICENSE="GPLv2"
SLOT="${PV}"
KEYWORDS="amd64 ~x86"
+
IUSE="bluetooth
desktop
ikconfig
@@ -54,6 +55,8 @@ $EOUT"
src_install() {
emake modules_install INSTALL_MOD_PATH="${D}"
+ rm "${D}/lib64/modules/${PV}/source"
+ rm "${D}/lib64/modules/${PV}/build"
dodir /boot
insinto /boot