summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-04-29 22:02:39 +0200
committerKarel Kočí <cynerd@email.cz>2017-04-29 23:58:57 +0200
commit09a210722e2d03129aed732ef11ed5a7f490b50d (patch)
tree0fa8dbbed439485877616b90287606edd8a0bce7 /sys-boot
parenta732501dc25554a257a8343cc630aa9ec17d5e79 (diff)
downloadgentoo-personal-overlay-09a210722e2d03129aed732ef11ed5a7f490b50d.tar.gz
gentoo-personal-overlay-09a210722e2d03129aed732ef11ed5a7f490b50d.tar.bz2
gentoo-personal-overlay-09a210722e2d03129aed732ef11ed5a7f490b50d.zip
Some more configs for linux
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/linux/files/configs/base3
-rw-r--r--sys-boot/linux/files/configs/desktop8
-rw-r--r--sys-boot/linux/files/configs/x86_641
-rw-r--r--sys-boot/linux/linux-4.10.13.ebuild5
4 files changed, 15 insertions, 2 deletions
diff --git a/sys-boot/linux/files/configs/base b/sys-boot/linux/files/configs/base
index bfb570a..d6e1f52 100644
--- a/sys-boot/linux/files/configs/base
+++ b/sys-boot/linux/files/configs/base
@@ -34,6 +34,9 @@ CONFIG_NLS_CODEPAGE_852=m
CONFIG_NLS_CODEPAGE_850=m
CONFIG_NLS_CODEPAGE_1250=m
CONFIG_NLS_ISO8859_2=m
+# FS Cache
+CONFIG_FSCACHE=m
+CONFIG_CACHEFILES=m
# Recovery from HW memory failures
CONFIG_MEMORY_FAILURE=y
diff --git a/sys-boot/linux/files/configs/desktop b/sys-boot/linux/files/configs/desktop
index 5dc6c7e..d5ef394 100644
--- a/sys-boot/linux/files/configs/desktop
+++ b/sys-boot/linux/files/configs/desktop
@@ -15,6 +15,14 @@ CONFIG_HID_BATTERY_STRENGTH=y
# Graphic (just intel for now)
CONFIG_DRM_I915=y
+# Virtual GEM
+CONFIG_DRM_VGEM=m
+
+# DMA
+CONFIG_INTEL_IDMA64=m
+CONFIG_ASYNC_TX_DMA=y
+# PHY
+CONFIG_GENERIC_PHY=y
# Multimedia (camera and such)
CONFIG_MEDIA_SUPPORT=m
diff --git a/sys-boot/linux/files/configs/x86_64 b/sys-boot/linux/files/configs/x86_64
index c4eb53a..880a13f 100644
--- a/sys-boot/linux/files/configs/x86_64
+++ b/sys-boot/linux/files/configs/x86_64
@@ -17,6 +17,7 @@ CONFIG_CRYPTO_USER_API_SKCIPHER=y
# I think that I have efi almost everywhere now
CONFIG_EFI=y
+CONFIG_EFI_STUB=y
CONFIG_EFI_VARS=y
CONFIG_EFIVAR_FS=m
diff --git a/sys-boot/linux/linux-4.10.13.ebuild b/sys-boot/linux/linux-4.10.13.ebuild
index 19b339a..cb9697b 100644
--- a/sys-boot/linux/linux-4.10.13.ebuild
+++ b/sys-boot/linux/linux-4.10.13.ebuild
@@ -24,6 +24,7 @@ DEPEND=""
RDEPEND="${DEPEND}"
src_configure() {
+ # Fix ARCH variable
[ "$ARCH" = "amd64" ] && ARCH="x86"
emake mrproper
@@ -40,13 +41,13 @@ src_configure() {
(
cd "${S}"
"${FILESDIR}"/config_prepare.sh $ARGS
- ) || fail
+ ) || die "Configuration application failed"
# Process changes
emake olddefconfig 2>/dev/null
# Check changes
- eerror "$("${FILESDIR}"/config_miss.sh $ARGS)" || fail
+ OUT="$("${FILESDIR}"/config_miss.sh $ARGS)" || die "$OUT"
}
src_install() {