summaryrefslogtreecommitdiff
path: root/sys-boot/linux/linux-4.10.13.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-04-29 22:02:39 +0200
committerKarel Kočí <cynerd@email.cz>2017-04-29 23:58:57 +0200
commit09a210722e2d03129aed732ef11ed5a7f490b50d (patch)
tree0fa8dbbed439485877616b90287606edd8a0bce7 /sys-boot/linux/linux-4.10.13.ebuild
parenta732501dc25554a257a8343cc630aa9ec17d5e79 (diff)
downloadgentoo-personal-overlay-09a210722e2d03129aed732ef11ed5a7f490b50d.tar.gz
gentoo-personal-overlay-09a210722e2d03129aed732ef11ed5a7f490b50d.tar.bz2
gentoo-personal-overlay-09a210722e2d03129aed732ef11ed5a7f490b50d.zip
Some more configs for linux
Diffstat (limited to 'sys-boot/linux/linux-4.10.13.ebuild')
-rw-r--r--sys-boot/linux/linux-4.10.13.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-boot/linux/linux-4.10.13.ebuild b/sys-boot/linux/linux-4.10.13.ebuild
index 19b339a..cb9697b 100644
--- a/sys-boot/linux/linux-4.10.13.ebuild
+++ b/sys-boot/linux/linux-4.10.13.ebuild
@@ -24,6 +24,7 @@ DEPEND=""
RDEPEND="${DEPEND}"
src_configure() {
+ # Fix ARCH variable
[ "$ARCH" = "amd64" ] && ARCH="x86"
emake mrproper
@@ -40,13 +41,13 @@ src_configure() {
(
cd "${S}"
"${FILESDIR}"/config_prepare.sh $ARGS
- ) || fail
+ ) || die "Configuration application failed"
# Process changes
emake olddefconfig 2>/dev/null
# Check changes
- eerror "$("${FILESDIR}"/config_miss.sh $ARGS)" || fail
+ OUT="$("${FILESDIR}"/config_miss.sh $ARGS)" || die "$OUT"
}
src_install() {