summaryrefslogtreecommitdiff
path: root/media-libs/gst-plugins-ugly
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-10-16 12:15:09 +0200
committerKarel Kočí <cynerd@email.cz>2017-10-16 12:15:09 +0200
commit532307dfe224f104dea4eb19e14bbf41cd1920c5 (patch)
tree6bcfc26e73ec6ce3aae9958f5db2690342d421fd /media-libs/gst-plugins-ugly
parentc6d2fe682d2afb4d3182c6441d65b847f49289c8 (diff)
downloadgentoo-personal-overlay-532307dfe224f104dea4eb19e14bbf41cd1920c5.tar.gz
gentoo-personal-overlay-532307dfe224f104dea4eb19e14bbf41cd1920c5.tar.bz2
gentoo-personal-overlay-532307dfe224f104dea4eb19e14bbf41cd1920c5.zip
Add gst plugins with experimental use flag
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/Manifest1
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/Manifest b/media-libs/gst-plugins-ugly/Manifest
new file mode 100644
index 0000000..6342f9c
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/Manifest
@@ -0,0 +1 @@
+DIST gst-plugins-ugly-1.12.3.tar.xz 903784 SHA256 e88ca584c94ea78eeecbf3af00ef7f134b66bdee7408aa4aa6c547235e060052 SHA512 9ca5769c325df3d2d97ba83d785fab08da5119f6d26c4ac4db72853af143477ea8fb7087464a8614b6e59f384463ac01087ee76cec2af8acd80a4dc15e392e34 WHIRLPOOL e908fb96fc5694c10c16b7e5aeae4a6f7945aaa324074cacc3ec10b84b53ef738ee8c77d6f0983a02e7868275ba26ada14153d7046d85bfdb57f310e59793657
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3-r1.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3-r1.ebuild
new file mode 100644
index 0000000..8b04f88
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc +experimental"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure $(use_enable experimental)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}