summaryrefslogtreecommitdiff
path: root/media-libs/gst-plugins-base
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-10-16 12:15:09 +0200
committerKarel Kočí <cynerd@email.cz>2017-10-16 12:15:09 +0200
commit532307dfe224f104dea4eb19e14bbf41cd1920c5 (patch)
tree6bcfc26e73ec6ce3aae9958f5db2690342d421fd /media-libs/gst-plugins-base
parentc6d2fe682d2afb4d3182c6441d65b847f49289c8 (diff)
downloadgentoo-personal-overlay-532307dfe224f104dea4eb19e14bbf41cd1920c5.tar.gz
gentoo-personal-overlay-532307dfe224f104dea4eb19e14bbf41cd1920c5.tar.bz2
gentoo-personal-overlay-532307dfe224f104dea4eb19e14bbf41cd1920c5.zip
Add gst plugins with experimental use flag
Diffstat (limited to 'media-libs/gst-plugins-base')
-rw-r--r--media-libs/gst-plugins-base/Manifest1
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-1.12.3-r1.ebuild90
-rw-r--r--media-libs/gst-plugins-base/metadata.xml12
3 files changed, 103 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-base/Manifest b/media-libs/gst-plugins-base/Manifest
new file mode 100644
index 0000000..ffd18f8
--- /dev/null
+++ b/media-libs/gst-plugins-base/Manifest
@@ -0,0 +1 @@
+DIST gst-plugins-base-1.12.3.tar.xz 3117364 SHA256 d3d37b8489d37fa0018973d850bd2067b98af335fef2fa543ee7d40359e3cea5 SHA512 d32f71836e25081b00040709a2184da85489e5af90902a0b27b820a478f5805bde93a04cefaeabf36dde53c16ad12f2816777cc195f1e027f19d1883e088e2b2 WHIRLPOOL e81c3183a70b121412bc455a4f93501e2fab7bf241a66f903446115891ab66ee78d570b01a4eaa5eb7971a7233f3fabf10a71c398bb4205beea6dbfb4280bcdf
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-1.12.3-r1.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-1.12.3-r1.ebuild
new file mode 100644
index 0000000..2bb4d82
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-1.12.3-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-base"
+
+inherit gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="alsa +introspection ivorbis +ogg +orc +pango theora +vorbis X +experimental"
+REQUIRED_USE="
+ ivorbis? ( ogg )
+ theora? ( ogg )
+ vorbis? ( ogg )
+"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:1.0[introspection?,${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+ ivorbis? ( >=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}] )
+ ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
+ orc? ( >=dev-lang/orc-0.4.24[${MULTILIB_USEDEP}] )
+ pango? ( >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}] )
+ theora? ( >=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}] )
+ vorbis? ( >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXv-1.0.10[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ X? (
+ >=x11-proto/videoproto-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )
+"
+RDEPEND+="!<media-libs/gst-plugins-bad-1.11.90:1.0" # rawparse move
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure \
+ $(use_enable alsa) \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable experimental) \
+ $(use_enable ivorbis) \
+ $(use_enable ogg) \
+ $(use_enable orc) \
+ $(use_enable pango) \
+ $(use_enable theora) \
+ $(use_enable vorbis) \
+ $(use_enable X x) \
+ $(use_enable X xshm) \
+ $(use_enable X xvideo) \
+ --enable-iso-codes \
+ --enable-zlib \
+ --disable-debug \
+ --disable-examples \
+ --disable-static
+ # cdparanoia and libvisual are split out, per leio's request
+
+ # bug #366931, flag-o-matic for the whole thing is overkill
+ if [[ ${CHOST} == *86-*-darwin* ]] ; then
+ sed -i \
+ -e '/FLAGS = /s|-O[23]|-O1|g' \
+ gst/audioconvert/Makefile \
+ gst/volume/Makefile || die
+ fi
+
+ if multilib_is_native_abi; then
+ local x
+ for x in libs plugins; do
+ ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+ done
+ fi
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-libs/gst-plugins-base/metadata.xml b/media-libs/gst-plugins-base/metadata.xml
new file mode 100644
index 0000000..1d80bb2
--- /dev/null
+++ b/media-libs/gst-plugins-base/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gstreamer@gentoo.org</email>
+ <name>GStreamer package maintainers</name>
+</maintainer>
+<use>
+ <flag name="ivorbis">Enable integer based vorbis decoder</flag>
+ <flag name="pango">Enable pango GStreamer plugin</flag>
+</use>
+</pkgmetadata>