summaryrefslogtreecommitdiff
path: root/dev-util/laminar/laminar-0.6.0.5.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-03-07 23:23:16 +0100
committerKarel Kočí <cynerd@email.cz>2019-03-07 23:23:16 +0100
commit06542c4911d586e0b4c709f683e030af9f859dae (patch)
treed0900b8ef6c6f86d0d68bee4212336e2bf9fb70b /dev-util/laminar/laminar-0.6.0.5.ebuild
parentff8ed7e3a8a75d53c3ae56b9fcd622825d5f3aa4 (diff)
downloadgentoo-personal-overlay-06542c4911d586e0b4c709f683e030af9f859dae.tar.gz
gentoo-personal-overlay-06542c4911d586e0b4c709f683e030af9f859dae.tar.bz2
gentoo-personal-overlay-06542c4911d586e0b4c709f683e030af9f859dae.zip
laminar: try to bump and improve init script
Diffstat (limited to 'dev-util/laminar/laminar-0.6.0.5.ebuild')
-rw-r--r--dev-util/laminar/laminar-0.6.0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/laminar/laminar-0.6.0.5.ebuild b/dev-util/laminar/laminar-0.6.0.5.ebuild
new file mode 100644
index 0000000..6712c35
--- /dev/null
+++ b/dev-util/laminar/laminar-0.6.0.5.ebuild
@@ -0,0 +1,29 @@
+EAPI=6
+
+inherit cmake-utils
+
+HASHV="b15166e83b695666f61182ac34cbfefd1762501c"
+DESCRIPTION="Lightweight and modular Continuous Integration service for Linux"
+HOMEPAGE="http://laminar.ohwg.net/"
+SRC_URI="https://github.com/ohwgiles/${PN}/archive/${HASHV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/capnproto
+ dev-libs/rapidjson
+ dev-db/sqlite
+ dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/laminar-${HASHV}"
+
+MYCMAKEARGS="-DCMAKE_INSTALL_PREFIX=/"
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}/laminar.init" laminar
+}