summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-03-07 23:23:16 +0100
committerKarel Kočí <cynerd@email.cz>2019-03-07 23:23:16 +0100
commit06542c4911d586e0b4c709f683e030af9f859dae (patch)
treed0900b8ef6c6f86d0d68bee4212336e2bf9fb70b /dev-util
parentff8ed7e3a8a75d53c3ae56b9fcd622825d5f3aa4 (diff)
downloadgentoo-personal-overlay-06542c4911d586e0b4c709f683e030af9f859dae.tar.gz
gentoo-personal-overlay-06542c4911d586e0b4c709f683e030af9f859dae.tar.bz2
gentoo-personal-overlay-06542c4911d586e0b4c709f683e030af9f859dae.zip
laminar: try to bump and improve init script
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/laminar/Manifest2
-rwxr-xr-xdev-util/laminar/files/laminar.init9
-rw-r--r--dev-util/laminar/laminar-0.6.0.5.ebuild (renamed from dev-util/laminar/laminar-0.6.0.4.ebuild)10
3 files changed, 16 insertions, 5 deletions
diff --git a/dev-util/laminar/Manifest b/dev-util/laminar/Manifest
index ac25e23..2e866b2 100644
--- a/dev-util/laminar/Manifest
+++ b/dev-util/laminar/Manifest
@@ -1 +1 @@
-DIST laminar-0.6.0.4.tar.gz 81535 BLAKE2B 1acf451e119a2c4dab0feba27ec6de2ae73f0c7d029e241b9593c08276918a51daa99dba23e4d7b6fde4d3095245d89946d78306f18d1727bd67f1f784b32358 SHA512 cec10b482f1d06c8838e33526ed9202ad8e8580a3c857e038388d344954e5b170b0f1aa11212c786cad6dd4fa6bd3f9a4a1e6e4821664f7ec15d3ef45b4e21c0
+DIST laminar-0.6.0.5.tar.gz 83866 BLAKE2B a818654e8ba110263741cd10f62f5886ecc5c23eaad886b3651a501a1cb3c73dc79f20d11fd7b43e786054cc77c549159741c1153fd36acbecc311385d5cefe7 SHA512 70decf9b530deb78fa3b89aa47e2a973df7b7af88e0ac72ccde0137cbcb95b3f1951c67256b32e350ffedce76c5b903c3db234fd5fcafac6da98d62c7b4a2316
diff --git a/dev-util/laminar/files/laminar.init b/dev-util/laminar/files/laminar.init
new file mode 100755
index 0000000..98a475f
--- /dev/null
+++ b/dev-util/laminar/files/laminar.init
@@ -0,0 +1,9 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command=/usr/bin/laminard
+command_background=yes
+pidfile=/var/run/laminar.pid
+command_user=build
+error_logger=/usr/bin/logger
diff --git a/dev-util/laminar/laminar-0.6.0.4.ebuild b/dev-util/laminar/laminar-0.6.0.5.ebuild
index bff8169..6712c35 100644
--- a/dev-util/laminar/laminar-0.6.0.4.ebuild
+++ b/dev-util/laminar/laminar-0.6.0.5.ebuild
@@ -1,11 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
EAPI=6
inherit cmake-utils
-HASHV="cc7d9fa4dabffdbfa5224cc1e667bc96cfa8ee5e"
+HASHV="b15166e83b695666f61182ac34cbfefd1762501c"
DESCRIPTION="Lightweight and modular Continuous Integration service for Linux"
HOMEPAGE="http://laminar.ohwg.net/"
SRC_URI="https://github.com/ohwgiles/${PN}/archive/${HASHV}.tar.gz -> ${P}.tar.gz"
@@ -25,3 +22,8 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/laminar-${HASHV}"
MYCMAKEARGS="-DCMAKE_INSTALL_PREFIX=/"
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}/laminar.init" laminar
+}