summaryrefslogtreecommitdiff
path: root/dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-11-09 18:11:08 +0100
committerKarel Kočí <cynerd@email.cz>2020-11-09 18:11:08 +0100
commitce6a21dba9a416ab04de726425f4f7f13e807a69 (patch)
treecb1d2238fcc45ce08641c3014107da3806090a0a /dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild
parent7093a07e5b9b13636e8aa24a3bdb8282b7c067c5 (diff)
downloadgentoo-personal-overlay-ce6a21dba9a416ab04de726425f4f7f13e807a69.tar.gz
gentoo-personal-overlay-ce6a21dba9a416ab04de726425f4f7f13e807a69.tar.bz2
gentoo-personal-overlay-ce6a21dba9a416ab04de726425f4f7f13e807a69.zip
dev-utils/kconfig-frontends: add new package
Using latest hash from git at time of creation.
Diffstat (limited to 'dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild')
-rw-r--r--dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild b/dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild
new file mode 100644
index 0000000..8410361
--- /dev/null
+++ b/dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Kconfig frontends for NuttX"
+HOMEPAGE="https://bitbucket.org/nuttx/tools"
+HASH="9484147c12d051014f854852d59c21d75a9616bd"
+SRC_URI="https://bitbucket.org/nuttx/tools/get/${HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/nuttx-tools-${HASH:0:12}/kconfig-frontends"
+
+
+src_prepare() {
+ eapply_user
+ eautoreconf -i -f -v
+}
+
+src_configure() {
+ econf \
+ $(use_enable ncurses mconf)
+}