summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/kconfig-frontends/Manifest1
-rw-r--r--dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/kconfig-frontends/Manifest b/dev-util/kconfig-frontends/Manifest
new file mode 100644
index 0000000..2f3edf0
--- /dev/null
+++ b/dev-util/kconfig-frontends/Manifest
@@ -0,0 +1 @@
+DIST kconfig-frontends-20200721.tar.gz 1021232 BLAKE2B 01acc8d7dfc79e05aafccd2a346835ffb44ca3234b4b81ac69976de2ac6dc8734aad5dd2605612b815ce6c60a6f9dc18c927f7ea3d5c658db80a69f0a95cd7cb SHA512 a5dab0b9a859ad67bf849c954042ab149864ececabf8e5dd84375c2c7c1e60c6bff6016bdf29dc4cd1ddbf319f23761b67629f00a42ff3bf5726885b32bdf51d
diff --git a/dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild b/dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild
new file mode 100644
index 0000000..8410361
--- /dev/null
+++ b/dev-util/kconfig-frontends/kconfig-frontends-20200721.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Kconfig frontends for NuttX"
+HOMEPAGE="https://bitbucket.org/nuttx/tools"
+HASH="9484147c12d051014f854852d59c21d75a9616bd"
+SRC_URI="https://bitbucket.org/nuttx/tools/get/${HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPLv2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/nuttx-tools-${HASH:0:12}/kconfig-frontends"
+
+
+src_prepare() {
+ eapply_user
+ eautoreconf -i -f -v
+}
+
+src_configure() {
+ econf \
+ $(use_enable ncurses mconf)
+}