summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-01-23 13:37:50 +0100
committerKarel Kočí <cynerd@email.cz>2022-01-23 13:37:50 +0100
commit68e3f74b8af50bedd80fcd2c11fbee0901e7b34d (patch)
tree7c322f41b66d224ada80858bfe99bb35641478b0
parent6f34477f7b9914cab366b988346d672a1b38e2a5 (diff)
downloadgentoo-personal-overlay-68e3f74b8af50bedd80fcd2c11fbee0901e7b34d.tar.gz
gentoo-personal-overlay-68e3f74b8af50bedd80fcd2c11fbee0901e7b34d.tar.bz2
gentoo-personal-overlay-68e3f74b8af50bedd80fcd2c11fbee0901e7b34d.zip
gui-apps/wev: add new package
-rw-r--r--gui-apps/wev/Manifest1
-rw-r--r--gui-apps/wev/wev-1.0.0.ebuild38
-rw-r--r--profiles/desktop/wayland/packages1
3 files changed, 40 insertions, 0 deletions
diff --git a/gui-apps/wev/Manifest b/gui-apps/wev/Manifest
new file mode 100644
index 0000000..e4dd756
--- /dev/null
+++ b/gui-apps/wev/Manifest
@@ -0,0 +1 @@
+DIST wev-1.0.0.tar.gz 8647 BLAKE2B e777cf1f19a5ad051b81ccd878067ba043c5121f460aed26fa41c999812d9c52e30837cbcb72351de4e532f0427cb2e8f707ca1ddaa09d992cdff3c422638ec2 SHA512 01d933b485393b5c3cd7a2d11c3946b48701650d61117aba2ec7ff8b9633e03dc462b25013f1faeea0d6e90f45251a4c701df76a5f894869645c9a84243f937c
diff --git a/gui-apps/wev/wev-1.0.0.ebuild b/gui-apps/wev/wev-1.0.0.ebuild
new file mode 100644
index 0000000..9849d6a
--- /dev/null
+++ b/gui-apps/wev/wev-1.0.0.ebuild
@@ -0,0 +1,38 @@
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Wayland event viewer"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/wev"
+SRC_URI="https://git.sr.ht/~sircmpwn/wev/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ app-text/scdoc
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # Respect LDFLAGS
+ # Install to /usr/ not /usr/local/
+ sed -e 's/$(LIBS)/$(LIBS) $(LDFLAGS)/' \
+ -e 's/local//' \
+ -i Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+
+ default
+}
diff --git a/profiles/desktop/wayland/packages b/profiles/desktop/wayland/packages
index 5ea5a3b..72f5ba3 100644
--- a/profiles/desktop/wayland/packages
+++ b/profiles/desktop/wayland/packages
@@ -2,6 +2,7 @@ gui-wm/sway
gui-apps/myswaylock
gui-apps/wofi
gui-apps/rofimoji
+gui-apps/wev
# Output configuration
gui-apps/kanshi