summaryrefslogtreecommitdiff
path: root/gui-apps/wev/wev-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wev/wev-1.0.0.ebuild')
-rw-r--r--gui-apps/wev/wev-1.0.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gui-apps/wev/wev-1.0.0.ebuild b/gui-apps/wev/wev-1.0.0.ebuild
new file mode 100644
index 0000000..9849d6a
--- /dev/null
+++ b/gui-apps/wev/wev-1.0.0.ebuild
@@ -0,0 +1,38 @@
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Wayland event viewer"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/wev"
+SRC_URI="https://git.sr.ht/~sircmpwn/wev/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ app-text/scdoc
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # Respect LDFLAGS
+ # Install to /usr/ not /usr/local/
+ sed -e 's/$(LIBS)/$(LIBS) $(LDFLAGS)/' \
+ -e 's/local//' \
+ -i Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+
+ default
+}