aboutsummaryrefslogtreecommitdiff
path: root/pkgs.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-03-16 13:22:29 +0100
committerKarel Kočí <cynerd@email.cz>2023-03-16 22:00:43 +0100
commitda54fd0a08cb5d29cf0d52f1688736634ebe03cb (patch)
treefb78ec2353cab663b49497a599aa4dee4f865e8c /pkgs.nix
parentf4e8372bc0cd143ea30cd3c28ec581b73649cfe0 (diff)
downloadshellrc-da54fd0a08cb5d29cf0d52f1688736634ebe03cb.tar.gz
shellrc-da54fd0a08cb5d29cf0d52f1688736634ebe03cb.tar.bz2
shellrc-da54fd0a08cb5d29cf0d52f1688736634ebe03cb.zip
pkgs: fix build failure
Diffstat (limited to 'pkgs.nix')
-rw-r--r--pkgs.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/pkgs.nix b/pkgs.nix
index f171859..ec5be7f 100644
--- a/pkgs.nix
+++ b/pkgs.nix
@@ -19,14 +19,14 @@
shellrc-bash = pkgs.stdenvNoCC.mkDerivation {
name = "shellrc-bash";
src = ./.;
- propagatedBuildInputs = [shellrcPkgs.shellrc-generic];
+ nativeBuildInputs = [pkgs.installShellFiles];
installPhase = ''
mkdir -p "$out/etc/bashrc.d"
cp -r ./bashrc.d/. "$out/etc/bashrc.d/"
cat >"$out/etc/bashrc.d/shellrc" <<EOF
# Load ShellRC files
- for p in $NIX_PROFILES; do
- for sh in $p/etc/shellrc.d/*; do
+ for p in \$NIX_PROFILES; do
+ for sh in \$p/etc/shellrc.d/*; do
[ -r "\$sh" ] && . "\$sh"
done
done
@@ -36,17 +36,17 @@
done
'';
};
- shellrc-zsh = pkgs.stdenvNoCC.mkDerivation {
+ shellrc-zsh= pkgs.stdenvNoCC.mkDerivation {
name = "shellrc-zsh";
src = ./.;
- propagatedBuildInputs = [shellrcPkgs.shellrc-generic];
+ nativeBuildInputs = [pkgs.installShellFiles];
installPhase = ''
mkdir -p "$out/etc/zshrc.d"
cp -r ./zshrc.d/. "$out/etc/zshrc.d/"
cat >"$out/etc/zshrc.d/shellrc" <<EOF
# Load ShellRC files
- for p in $NIX_PROFILES; do
- for sh in $p/etc/shellrc.d/*; do
+ for profile in \''${=NIX_PROFILES}; do
+ for sh in \$profile/etc/shellrc.d/*; do
[ -r "\$sh" ] && . "\$sh"
done
done