aboutsummaryrefslogtreecommitdiff
path: root/pkgs.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-10-02 11:02:17 +0200
committerKarel Kočí <cynerd@email.cz>2024-10-02 11:02:17 +0200
commit699d10813cd26bec34a7e128c18d9198150f38e8 (patch)
treea1e60ae182947926aa9258ebecd0c67937f20575 /pkgs.nix
parent0adc7c32594913d0f4ec774a85cb03554cd719d4 (diff)
downloadshellrc-699d10813cd26bec34a7e128c18d9198150f38e8.tar.gz
shellrc-699d10813cd26bec34a7e128c18d9198150f38e8.tar.bz2
shellrc-699d10813cd26bec34a7e128c18d9198150f38e8.zip
pkgs/shellrc-user-setup: use rc files instead of profileHEADmaster
This should fix loading over SSH.
Diffstat (limited to 'pkgs.nix')
-rw-r--r--pkgs.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs.nix b/pkgs.nix
index a62e8b2..1f01470 100644
--- a/pkgs.nix
+++ b/pkgs.nix
@@ -41,12 +41,12 @@
cmdbash='eval $(shellrc-bash)'
cmdzsh='eval $(shellrc-zsh)'
if command -v shellrc-bash 2>/dev/null >&2 \
- && ! grep -qxF "$cmdbash" ~/.profile 2>/dev/null; then
- echo "$cmdbash" >>~/.profile
+ && ! grep -qxF "$cmdbash" ~/.bashrc 2>/dev/null; then
+ echo "$cmdbash" >>~/.bashrc
fi
if command -v shellrc-zsh 2>/dev/null >&2 \
- && ! grep -qxF "$cmdzsh" ~/.zprofile 2>/dev/null; then
- echo "$cmdzsh" >>~/.zprofile
+ && ! grep -qxF "$cmdzsh" ~/.zshrc 2>/dev/null; then
+ echo "$cmdzsh" >>~/.zshrc
fi
'';
};