aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPavel Pisa <pisa@cmp.felk.cvut.cz>2019-03-15 09:42:58 +0100
committerPavel Pisa <pisa@cmp.felk.cvut.cz>2019-03-15 09:42:58 +0100
commit526da12a50b3670d0af417756511a19e252d3cfb (patch)
tree23aa56bb2c1f29d0bc2070f909ce21e6695b9cf3 /debian/rules
parentdf8f379ac98ec8ddfafde57f211959e3073fc0de (diff)
downloadqtmips-526da12a50b3670d0af417756511a19e252d3cfb.tar.gz
qtmips-526da12a50b3670d0af417756511a19e252d3cfb.tar.bz2
qtmips-526da12a50b3670d0af417756511a19e252d3cfb.zip
Include Debian package build information.
Signed-off-by: Pavel Pisa <pisa@cmp.felk.cvut.cz>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..70ccde3
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+export DH_VERBOSE = 1
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed
+export QT_SELECT := qt5
+
+# --parallel
+
+%:
+ dh $@