summaryrefslogtreecommitdiff
path: root/updater-ng/patches
diff options
context:
space:
mode:
Diffstat (limited to 'updater-ng/patches')
-rw-r--r--updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch2
-rw-r--r--updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch2
-rw-r--r--updater-ng/patches/0003-utils-xxdi.pl-remove-dependency-on-File-Slurp.patch47
3 files changed, 49 insertions, 2 deletions
diff --git a/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch b/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch
index e54b550..1577c42 100644
--- a/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch
+++ b/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch
@@ -1,7 +1,7 @@
From 1048eccde0342f5aa3133623f9cafbfa92eaf039 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Thu, 21 May 2020 21:13:37 +0200
-Subject: [PATCH 1/2] configure.ac: fix check for busybox when cross compiling
+Subject: [PATCH 1/3] configure.ac: fix check for busybox when cross compiling
AC_CHECK_FILE works only if cross compilation is not performed. The
reason is that it tries to check for existence of file on native system.
diff --git a/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch b/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch
index 91c3d63..0ca5c20 100644
--- a/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch
+++ b/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch
@@ -1,7 +1,7 @@
From 6b57800e3b8836eefb39cb9f315faf6b35a8df3f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Sun, 31 May 2020 11:31:46 +0200
-Subject: [PATCH 2/2] configure.ac: check for plain Lua first instead of lua5.1
+Subject: [PATCH 2/3] configure.ac: check for plain Lua first instead of lua5.1
Checking for lua with version 5.1 is required for systems with single
version of Lua while lua5.1 is required for those providing multiple
diff --git a/updater-ng/patches/0003-utils-xxdi.pl-remove-dependency-on-File-Slurp.patch b/updater-ng/patches/0003-utils-xxdi.pl-remove-dependency-on-File-Slurp.patch
new file mode 100644
index 0000000..a655511
--- /dev/null
+++ b/updater-ng/patches/0003-utils-xxdi.pl-remove-dependency-on-File-Slurp.patch
@@ -0,0 +1,47 @@
+From 6e670a7a5f01be45ac7e1c98ab841deb7a6233fd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
+Date: Mon, 1 Jun 2020 09:58:28 +0200
+Subject: [PATCH 3/3] utils/xxdi.pl: remove dependency on File::Slurp
+
+---
+ configure.ac | 1 -
+ utils/xxdi.pl | 7 +++++--
+ 2 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7421534a..06a51365 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,7 +38,6 @@ AC_LINK_IFELSE(
+
+ AC_PATH_PROG([PERL], [perl])
+ AS_IF([test -z "$PERL"], [AC_MSG_ERROR([Missing perl interpreter])])
+-AX_PROG_PERL_MODULES([File::Slurp], , AC_MSG_ERROR(Perl modules File::Slurp is required))
+ AC_PATH_PROG([XXDI], [xxdi.pl],, [$ac_abs_confdir/utils])
+ AS_IF([test -z "$XXDI"], [AC_MSG_ERROR([Not able to locate xxdi.pl])])
+
+diff --git a/utils/xxdi.pl b/utils/xxdi.pl
+index 465e47a8..0e386922 100755
+--- a/utils/xxdi.pl
++++ b/utils/xxdi.pl
+@@ -14,12 +14,15 @@
+
+ use strict;
+ use warnings;
+-use File::Slurp qw(slurp);
+
+ die "Usage: xddi.pl VARIABLE_NAME INPUT OUTPUT" unless @ARGV == 3;
+
+ my $var_name = $ARGV[0];
+-my $indata = slurp($ARGV[1]);
++my $indata = do {
++ local $/;
++ open my $f, "<", $ARGV[1] or die "Could not open input $ARGV[1]: $!\n";
++ <$f>;
++};
+ my $len_data = length($indata);
+ my $num_digits_per_line = 12;
+
+--
+2.26.2
+