summaryrefslogtreecommitdiff
path: root/reforis-nextcloud-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'reforis-nextcloud-plugin')
-rw-r--r--reforis-nextcloud-plugin/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/reforis-nextcloud-plugin/Makefile b/reforis-nextcloud-plugin/Makefile
deleted file mode 100644
index 826146f..0000000
--- a/reforis-nextcloud-plugin/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2020 CZ.NIC z.s.p.o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=reforis-nextcloud-plugin
-PKG_VERSION:=0.1.0
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/reforis/reforis-nextcloud.git
-PKG_SOURCE_VERSION:=642806281c2a073f148b73ed3f1c1aa5532e243e
-
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_LICENSE_FILES:=LICENSE
-
-PKG_BUILD_DEPENDS:=\
- node/host \
- reforis-distutils/host \
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-include $(TOPDIR)/feeds/turrispackages/web/reforis/reforis/files/reforis-plugin.mk
-include $(TOPDIR)/feeds/turrispackages/web/reforis/reforis/files/reforis-translations.mk
-
-define Package/reforis-nextcloud-plugin
- TITLE:=reForis Nextcloud plugin
- URL:=https://gitlab.nic.cz/turris/reforis/reforis-nextcloud
- DEPENDS:=\
- +reforis \
- +foris-controller-storage-module
- VARIANT:=python3
-endef
-
-define Package/reforis-nextcloud-plugin/description
- reForis Storage plugin
-endef
-
-REFORIS_TRANSLATIONS:=cs
-
-$(eval $(call ReForisPlugin,reforis-nextcloud-plugin,reforis_nextcloud))
-# call BuildPackage <= assures OWR build system that this is package