summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo/files/autopkg-tag.mk
diff options
context:
space:
mode:
Diffstat (limited to 'personal-pkgs-repo/files/autopkg-tag.mk')
-rw-r--r--personal-pkgs-repo/files/autopkg-tag.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/personal-pkgs-repo/files/autopkg-tag.mk b/personal-pkgs-repo/files/autopkg-tag.mk
new file mode 100644
index 0000000..6fe08d4
--- /dev/null
+++ b/personal-pkgs-repo/files/autopkg-tag.mk
@@ -0,0 +1,8 @@
+# Autopkg tracking latest version tag
+AUTOPKG_VARIANT:=tag
+$(call include_mk, autopkg-common.mk)
+
+PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort | tail -1)
+PKG_VERSION:=$(subst v%,%,$(PKG_SOURCE_VERSION))
+
+$(eval $(call AUTOPKG_TAIL))