summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'personal-pkgs-repo/Makefile')
-rw-r--r--personal-pkgs-repo/Makefile21
1 files changed, 19 insertions, 2 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 81a539a..3b150e4 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.1
+PKG_VERSION:=1.2
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -16,7 +16,6 @@ include $(INCLUDE_DIR)/package.mk
define Package/$(PKG_NAME)
TITLE:=Package with repository key and meta dependencies
- DEPENDS:=+shellrc-zsh +shellrc-ash
endef
define Build/Compile
@@ -33,4 +32,22 @@ define Package/$(PKG_NAME)/install
$(INSTALL_CONF) ./files/updater.lua $(1)/etc/updater/conf.d/personal-pkgs.lua
endef
+BOARD=turris
+ifeq ($(CONFIG_TARGET_mvebu_Turris-Omnia),y)
+BOARD=omnia
+endif
+
+define Package/$(PKG_NAME)/postinst
+#!/bin/sh
+feedsfile="$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"
+sed -i '/^src\/gz personal/d' "$$feedsfile"
+echo "src/gz personal https://cynerd.cz/repo/turris3x/$(BOARD)" >> "$$feedsfile"
+endef
+
+define Package/$(PKG_NAME)/prerm
+#!/bin/sh
+feedsfile="$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"
+sed -i '/^src\/gz personal/d' "$$feedsfile"
+endef
+
$(eval $(call BuildPackage,$(PKG_NAME)))