summaryrefslogtreecommitdiff
path: root/healthcheck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'healthcheck/Makefile')
-rw-r--r--healthcheck/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/healthcheck/Makefile b/healthcheck/Makefile
new file mode 100644
index 0000000..8faa1fb
--- /dev/null
+++ b/healthcheck/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=healthcheck
+PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/healthcheck.git
+PKG_SOURCE_BRANCH:=dev
+
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/autopkg-branch.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/healthcheck
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Healthcheck
+ URL:=https://gitlab.nic.cz/turris/healthcheck
+ DEPENDS:=\
+ +python3-humanize \
+ +python3-rich \
+ +python3-crontab \
+ +python3-uci
+ VARIANT:=python3
+endef
+
+define Package/healthcheck/description
+ Turris router health checking tool.
+endef
+
+define Py3Package/healthcheck/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/cron.d
+ $(INSTALL_CONF) ./files/cron $(1)/etc/cron.d/healthcheck
+endef
+
+$(eval $(call Py3Package,healthcheck))
+$(eval $(call BuildPackage,healthcheck))
+$(eval $(call BuildPackage,healthcheck-src))