summaryrefslogtreecommitdiff
path: root/click
diff options
context:
space:
mode:
Diffstat (limited to 'click')
-rw-r--r--click/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/click/Makefile b/click/Makefile
new file mode 100644
index 0000000..438f14a
--- /dev/null
+++ b/click/Makefile
@@ -0,0 +1,24 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=click
+PKG_VERSION:=6.7
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=https://github.com/pallets/click/archive/$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=fc4cc00c4863833230d3af92af48abd4
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Python composable command line utility
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))