summaryrefslogtreecommitdiff
path: root/bigclown-leds/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'bigclown-leds/Makefile')
-rw-r--r--bigclown-leds/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/bigclown-leds/Makefile b/bigclown-leds/Makefile
new file mode 100644
index 0000000..5533588
--- /dev/null
+++ b/bigclown-leds/Makefile
@@ -0,0 +1,31 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-leds
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ TITLE:=BigCLown LEDs
+ DEPENDS:=+python3-paho-mqtt
+endef
+
+define Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_DATA) ./files/bigclown-leds $(1)/usr/bin/bigclown-leds
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-leds
+endef
+
+define Build/Compile
+ true
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))