summaryrefslogtreecommitdiff
path: root/bigclown-leds/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-03-05 23:47:25 +0100
committerKarel Kočí <cynerd@email.cz>2019-03-05 23:47:25 +0100
commit2847ac220defe13a6edb774892cbfb4cbc8e4a94 (patch)
tree4f06527a0c87a97b43aec4ddb45305afde01b23c /bigclown-leds/Makefile
parentd8cba12a38823fdcdb2fbbaaef3ce6fb37c4b474 (diff)
downloadopenwrt-personal-pkgs-2847ac220defe13a6edb774892cbfb4cbc8e4a94.tar.gz
openwrt-personal-pkgs-2847ac220defe13a6edb774892cbfb4cbc8e4a94.tar.bz2
openwrt-personal-pkgs-2847ac220defe13a6edb774892cbfb4cbc8e4a94.zip
bigclown-leds: Add package
Diffstat (limited to 'bigclown-leds/Makefile')
-rw-r--r--bigclown-leds/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/bigclown-leds/Makefile b/bigclown-leds/Makefile
new file mode 100644
index 0000000..5533588
--- /dev/null
+++ b/bigclown-leds/Makefile
@@ -0,0 +1,31 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-leds
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ TITLE:=BigCLown LEDs
+ DEPENDS:=+python3-paho-mqtt
+endef
+
+define Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_DATA) ./files/bigclown-leds $(1)/usr/bin/bigclown-leds
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-leds
+endef
+
+define Build/Compile
+ true
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))