summaryrefslogtreecommitdiff
path: root/bigclown-control-tools
diff options
context:
space:
mode:
Diffstat (limited to 'bigclown-control-tools')
-rw-r--r--bigclown-control-tools/Makefile28
-rwxr-xr-xbigclown-control-tools/files/bch9
2 files changed, 37 insertions, 0 deletions
diff --git a/bigclown-control-tools/Makefile b/bigclown-control-tools/Makefile
new file mode 100644
index 0000000..e1decb7
--- /dev/null
+++ b/bigclown-control-tools/Makefile
@@ -0,0 +1,28 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-control-tools
+PKG_RELEASE:=3
+PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-control-tool.git
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+include $(TOPDIR)/feeds/personal/autopkg-tag.mk
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=BigCLown control tools
+ DEPENDS:=+python3 +click-log +python3-influxdb +python3-pyyaml +python3-pyserial +python3-simplejson
+endef
+
+define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) ./files/bch $(1)/usr/bin/bch
+endef
+
+define Build/Compile
+ sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/bigclown-control-tools/files/bch b/bigclown-control-tools/files/bch
new file mode 100755
index 0000000..a473b30
--- /dev/null
+++ b/bigclown-control-tools/files/bch
@@ -0,0 +1,9 @@
+#!/usr/bin/python3.6
+import bch
+import sys
+from pkg_resources import load_entry_point
+
+if __name__ == '__main__':
+ sys.exit(
+ load_entry_point('bch', 'console_scripts', 'bch')()
+ )