summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--bigclown-control-tool/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/bigclown-control-tool/Makefile b/bigclown-control-tool/Makefile
index 38730f6..f052418 100644
--- a/bigclown-control-tool/Makefile
+++ b/bigclown-control-tool/Makefile
@@ -26,6 +26,11 @@ define Package/$(PKG_NAME)
DEPENDS:=+python3-click-log +python3-paho-mqtt +python3-pyserial +python3-yaml +python3-simplejson
endef
+define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
define Build/Compile
sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
$(call Py3Build/Compile/Default)