summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--reforis-nextcloud-plugin/Makefile47
-rw-r--r--reforis-storage-plugin/Makefile47
2 files changed, 94 insertions, 0 deletions
diff --git a/reforis-nextcloud-plugin/Makefile b/reforis-nextcloud-plugin/Makefile
new file mode 100644
index 0000000..15f3008
--- /dev/null
+++ b/reforis-nextcloud-plugin/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2020 CZ.NIC z.s.p.o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=reforis-nextcloud-plugin
+PKG_VERSION:=0.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/reforis/reforis-nextcloud.git
+PKG_SOURCE_VERSION:=6a7bb0def694b1ec36e7a77137f1620d2b476bd7
+
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=\
+ node/host \
+ reforis-distutils/host \
+
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+include ../reforis/files/reforis-plugin.mk
+include ../reforis/files/reforis-translations.mk
+
+define Package/reforis-nextcloud-plugin
+ TITLE:=reForis Nextcloud plugin
+ URL:=https://gitlab.nic.cz/turris/reforis/reforis-nextcloud
+ DEPENDS:=\
+ +reforis \
+ +foris-controller-storage-module
+ VARIANT:=python3
+endef
+
+define Package/reforis-nextcloud-plugin/description
+ reForis Storage plugin
+endef
+
+REFORIS_TRANSLATIONS:=cs
+
+$(eval $(call ReForisPlugin,reforis-nextcloud-plugin,reforis_nextcloud))
+# call BuildPackage <= assures OWR build system that this is package
diff --git a/reforis-storage-plugin/Makefile b/reforis-storage-plugin/Makefile
new file mode 100644
index 0000000..02e1ede
--- /dev/null
+++ b/reforis-storage-plugin/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2020 CZ.NIC z.s.p.o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=reforis-storage-plugin
+PKG_VERSION:=0.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/reforis/reforis-storage.git
+PKG_SOURCE_VERSION:=a4ac8eeca36186960a80c573334faab73f4e478d
+
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=\
+ node/host \
+ reforis-distutils/host \
+
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+include ../reforis/files/reforis-plugin.mk
+include ../reforis/files/reforis-translations.mk
+
+define Package/reforis-storage-plugin
+ TITLE:=reForis Storage plugin
+ URL:=https://gitlab.nic.cz/turris/reforis/reforis-storage
+ DEPENDS:=\
+ +reforis \
+ +foris-controller-storage-module
+ VARIANT:=python3
+endef
+
+define Package/reforis-storage-plugin/description
+ reForis Storage plugin
+endef
+
+REFORIS_TRANSLATIONS:=cs
+
+$(eval $(call ReForisPlugin,reforis-storage-plugin,reforis_storage))
+# call BuildPackage <= assures OWR build system that this is package