summaryrefslogtreecommitdiff
path: root/user-notify
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-10-08 11:56:45 +0200
committerKarel Kočí <karel.koci@nic.cz>2020-10-08 11:56:45 +0200
commit464f5d8de44e832b05f4104fb51dbde5dd6e77ec (patch)
tree1156ce1c97478642fe22bdf81c7d44ef7825ff13 /user-notify
parent26edea6c1cb08dee516af1762381d9cafcb8f812 (diff)
downloadopenwrt-personal-pkgs-464f5d8de44e832b05f4104fb51dbde5dd6e77ec.tar.gz
openwrt-personal-pkgs-464f5d8de44e832b05f4104fb51dbde5dd6e77ec.tar.bz2
openwrt-personal-pkgs-464f5d8de44e832b05f4104fb51dbde5dd6e77ec.zip
user-notify: add to test new version
Diffstat (limited to 'user-notify')
-rw-r--r--user-notify/Makefile60
-rw-r--r--user-notify/files/user_notify.cron2
-rw-r--r--user-notify/files/user_notify.uci27
3 files changed, 89 insertions, 0 deletions
diff --git a/user-notify/Makefile b/user-notify/Makefile
new file mode 100644
index 0000000..1a690a1
--- /dev/null
+++ b/user-notify/Makefile
@@ -0,0 +1,60 @@
+#
+## Copyright (C) 2018-2020 CZ.NIC z.s.p.o. (https://www.nic.cz/)
+#
+## This is free software, licensed under the GNU General Public License v3.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=user-notify
+PKG_VERSION:=61.5
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/user-notify.git
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
+
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+PKG_LICENSE:=GPL-3.0-or-later
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/user-notify
+ TITLE:=Turris user notifications
+ DEPENDS:=+at +msmtp +ca-certificates +crypto-wrapper +sentinel-certgen +gettext-tools +create_notification
+endef
+
+Build/Compile:=:
+
+define Package/user-notify/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/list_notifications $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/notifier $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/user-notify-cleaner $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/user-notify-display $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/user_notify.uci $(1)/etc/config/user_notify
+
+ $(INSTALL_DIR) $(1)/etc/cron.d
+ $(INSTALL_DATA) ./files/user_notify.cron $(1)/etc/cron.d/user_notify
+endef
+
+define Package/user-notify/conffiles
+/etc/config/user_notify
+endef
+
+
+define Package/create_notification
+ TITLE:=Create Turris user notification
+ DEPENDS:=+gettext-tools
+endef
+
+define Package/create_notification/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/create_notification $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,user-notify))
+$(eval $(call BuildPackage,create_notification))
diff --git a/user-notify/files/user_notify.cron b/user-notify/files/user_notify.cron
new file mode 100644
index 0000000..63e77e8
--- /dev/null
+++ b/user-notify/files/user_notify.cron
@@ -0,0 +1,2 @@
+MAILTO=""
+*/5 * * * * root /usr/bin/notifier
diff --git a/user-notify/files/user_notify.uci b/user-notify/files/user_notify.uci
new file mode 100644
index 0000000..d654387
--- /dev/null
+++ b/user-notify/files/user_notify.uci
@@ -0,0 +1,27 @@
+package 'user_notify'
+
+config smtp smtp
+ option enable 0
+ option use_turris_smtp 1
+ option sender_name 'turris'
+ #option from 'router@example.com'
+ #option server 'example.com'
+ #option port 465
+ #option username 'router'
+ #option password '1234'
+ #option security 'ssl' # or 'starttls' or 'none'
+ #list to 'user@example.com'
+
+config notifications notifications
+ # 1: restarts
+ # 2: restarts and errors
+ # 3: restarts, errors and updates
+ option severity 1
+ # Send news severity
+ option news 1
+
+config reboot reboot
+ # Days, how long to wait before reboot (only if notifications are enabled)
+ option delay 3
+ # If present, schedule the reboot to specified time
+ option time '03:30'