summaryrefslogtreecommitdiff
path: root/user-notify/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-10-22 14:25:45 +0200
committerKarel Kočí <cynerd@email.cz>2020-10-22 14:25:45 +0200
commit55b66a930c086d57f567e5d72ec7575df4a18fcc (patch)
tree48b461e8c06a86d4f0e787897a560d96a1559f08 /user-notify/Makefile
parentcb1b57931e787facba5335cc3ca85613089a91cf (diff)
downloadopenwrt-personal-pkgs-55b66a930c086d57f567e5d72ec7575df4a18fcc.tar.gz
openwrt-personal-pkgs-55b66a930c086d57f567e5d72ec7575df4a18fcc.tar.bz2
openwrt-personal-pkgs-55b66a930c086d57f567e5d72ec7575df4a18fcc.zip
user-notify: remove
Diffstat (limited to 'user-notify/Makefile')
-rw-r--r--user-notify/Makefile61
1 files changed, 0 insertions, 61 deletions
diff --git a/user-notify/Makefile b/user-notify/Makefile
deleted file mode 100644
index bc34cbd..0000000
--- a/user-notify/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-#
-## Copyright (C) 2018-2020 CZ.NIC z.s.p.o. (https://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v3.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=user-notify
-PKG_VERSION:=61.5
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/user-notify.git
-#PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_SOURCE_VERSION:=29ce1dd97d8c4fdf12590efd34c49cf3ebe0b5e4
-
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-PKG_LICENSE:=GPL-3.0-or-later
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/user-notify
- TITLE:=Turris user notifications
- DEPENDS:=+at +msmtp +ca-certificates +crypto-wrapper +sentinel-certgen +gettext-tools +create_notification
-endef
-
-Build/Compile:=:
-
-define Package/user-notify/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/list_notifications $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/notifier $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/user-notify-cleaner $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/user-notify-display $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/user_notify.uci $(1)/etc/config/user_notify
-
- $(INSTALL_DIR) $(1)/etc/cron.d
- $(INSTALL_DATA) ./files/user_notify.cron $(1)/etc/cron.d/user_notify
-endef
-
-define Package/user-notify/conffiles
-/etc/config/user_notify
-endef
-
-
-define Package/create_notification
- TITLE:=Create Turris user notification
- DEPENDS:=+gettext-tools
-endef
-
-define Package/create_notification/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/scripts/create_notification $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,user-notify))
-$(eval $(call BuildPackage,create_notification))