summaryrefslogtreecommitdiff
path: root/updater-supervisor
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-03-11 11:09:36 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-03-11 11:09:36 +0100
commit70adb60173e18c5e02c6e604b0451a672ec2e4c1 (patch)
tree581613e2aba03ecc60096bcdb51cb3b79a976374 /updater-supervisor
parentf7f89f29b85e88e2ce11d9597039b2ee716b31f1 (diff)
downloadopenwrt-personal-pkgs-70adb60173e18c5e02c6e604b0451a672ec2e4c1.tar.gz
openwrt-personal-pkgs-70adb60173e18c5e02c6e604b0451a672ec2e4c1.tar.bz2
openwrt-personal-pkgs-70adb60173e18c5e02c6e604b0451a672ec2e4c1.zip
Try to split updater-ng to multiple packages
Diffstat (limited to 'updater-supervisor')
-rw-r--r--updater-supervisor/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/updater-supervisor/Makefile b/updater-supervisor/Makefile
new file mode 100644
index 0000000..30f1d42
--- /dev/null
+++ b/updater-supervisor/Makefile
@@ -0,0 +1,41 @@
+#
+## Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=updater-supervisor
+PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/supervisor.git
+PKG_SOURCE_BRANCH:=master
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+
+include $(INCLUDE_DIR)/autopkg-branch.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+
+define Package/$(PKG_NAME)
+ TITLE:=Next generation updater supervisor and its library
+ DEPENDS:=+updater-ng +python3-light +python3-uci +pkglists +l10n_supported
+ VARIANT:=python3
+endef
+
+define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/immediate_reboot.init $(1)/etc/init.d/updater-journal-recover
+ $(INSTALL_DIR) $(1)/etc/cron.d
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/files/cron $(1)/etc/cron.d/updater
+ $(INSTALL_DIR) $(1)/etc/updater/hook_postupdate
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/hook_postupdate $(1)/etc/updater/hook_postupdate/99_approvals_cleanup
+endef
+
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)-src))