summaryrefslogtreecommitdiff
path: root/updater-supervisor
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-06-18 14:14:08 +0200
committerKarel Kočí <karel.koci@nic.cz>2019-06-18 14:14:08 +0200
commit2e3e616bf96c08083cde8748c04f2e6d2ed263e1 (patch)
tree1469c53d3b4676e56caacc37f2514b67c21f45b4 /updater-supervisor
parent63bdb87a3a269ed0c5cb7fdfb8b9c0a8e4ae76bf (diff)
downloadopenwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.tar.gz
openwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.tar.bz2
openwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.zip
Drop rolling updater for now
Diffstat (limited to 'updater-supervisor')
-rw-r--r--updater-supervisor/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/updater-supervisor/Makefile b/updater-supervisor/Makefile
deleted file mode 100644
index 30f1d42..0000000
--- a/updater-supervisor/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-## Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=updater-supervisor
-PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/supervisor.git
-PKG_SOURCE_BRANCH:=master
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-
-include $(INCLUDE_DIR)/autopkg-branch.mk
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-
-define Package/$(PKG_NAME)
- TITLE:=Next generation updater supervisor and its library
- DEPENDS:=+updater-ng +python3-light +python3-uci +pkglists +l10n_supported
- VARIANT:=python3
-endef
-
-define Py3Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/immediate_reboot.init $(1)/etc/init.d/updater-journal-recover
- $(INSTALL_DIR) $(1)/etc/cron.d
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/files/cron $(1)/etc/cron.d/updater
- $(INSTALL_DIR) $(1)/etc/updater/hook_postupdate
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/hook_postupdate $(1)/etc/updater/hook_postupdate/99_approvals_cleanup
-endef
-
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)-src))