summaryrefslogtreecommitdiff
path: root/updater-opkg-wrapper/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-03-11 11:09:36 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-03-11 11:09:36 +0100
commit70adb60173e18c5e02c6e604b0451a672ec2e4c1 (patch)
tree581613e2aba03ecc60096bcdb51cb3b79a976374 /updater-opkg-wrapper/Makefile
parentf7f89f29b85e88e2ce11d9597039b2ee716b31f1 (diff)
downloadopenwrt-personal-pkgs-70adb60173e18c5e02c6e604b0451a672ec2e4c1.tar.gz
openwrt-personal-pkgs-70adb60173e18c5e02c6e604b0451a672ec2e4c1.tar.bz2
openwrt-personal-pkgs-70adb60173e18c5e02c6e604b0451a672ec2e4c1.zip
Try to split updater-ng to multiple packages
Diffstat (limited to 'updater-opkg-wrapper/Makefile')
-rw-r--r--updater-opkg-wrapper/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/updater-opkg-wrapper/Makefile b/updater-opkg-wrapper/Makefile
new file mode 100644
index 0000000..2c795f9
--- /dev/null
+++ b/updater-opkg-wrapper/Makefile
@@ -0,0 +1,34 @@
+#
+## Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=updater-opkg-wrapper
+PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/opkg-wrapper.git
+PKG_SOURCE_BRANCH:=master
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+
+include $(INCLUDE_DIR)/autopkg-branch.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ TITLE:=OPKG compatibility wrapper for next generation updater
+ DEPENDS:=+opkg +updater-ng +localrepo
+endef
+
+define Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/opkg $(1)/usr/bin/opkg-pkgupdate-wrapper.sh
+ $(INSTALL_DIR) $(1)/etc/updater/conf.d
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/opkg.lua $(1)/etc/updater/conf.d/opkg.lua
+ $(INSTALL_DIR) $(1)/etc/updater/opkg-ignore
+ touch $(1)/etc/updater/opkg-ignore/.keep
+endef
+
+Build/Compile:=
+
+$(eval $(call BuildPackage,$(PKG_NAME)))