summaryrefslogtreecommitdiff
path: root/updater-opkg-wrapper/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-06-18 14:14:08 +0200
committerKarel Kočí <karel.koci@nic.cz>2019-06-18 14:14:08 +0200
commit2e3e616bf96c08083cde8748c04f2e6d2ed263e1 (patch)
tree1469c53d3b4676e56caacc37f2514b67c21f45b4 /updater-opkg-wrapper/Makefile
parent63bdb87a3a269ed0c5cb7fdfb8b9c0a8e4ae76bf (diff)
downloadopenwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.tar.gz
openwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.tar.bz2
openwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.zip
Drop rolling updater for now
Diffstat (limited to 'updater-opkg-wrapper/Makefile')
-rw-r--r--updater-opkg-wrapper/Makefile34
1 files changed, 0 insertions, 34 deletions
diff --git a/updater-opkg-wrapper/Makefile b/updater-opkg-wrapper/Makefile
deleted file mode 100644
index 2c795f9..0000000
--- a/updater-opkg-wrapper/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-## Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=updater-opkg-wrapper
-PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/opkg-wrapper.git
-PKG_SOURCE_BRANCH:=master
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-
-include $(INCLUDE_DIR)/autopkg-branch.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/$(PKG_NAME)
- TITLE:=OPKG compatibility wrapper for next generation updater
- DEPENDS:=+opkg +updater-ng +localrepo
-endef
-
-define Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/opkg $(1)/usr/bin/opkg-pkgupdate-wrapper.sh
- $(INSTALL_DIR) $(1)/etc/updater/conf.d
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/opkg.lua $(1)/etc/updater/conf.d/opkg.lua
- $(INSTALL_DIR) $(1)/etc/updater/opkg-ignore
- touch $(1)/etc/updater/opkg-ignore/.keep
-endef
-
-Build/Compile:=
-
-$(eval $(call BuildPackage,$(PKG_NAME)))