summaryrefslogtreecommitdiff
path: root/updater-ng
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-04-17 12:01:41 +0200
committerKarel Kočí <cynerd@email.cz>2020-04-17 12:02:36 +0200
commite0d55f0cfac63f4eea42203ab04364d9f47bc5ef (patch)
treed6f0ba35e1c4e404b95b597a1ff6245f06fab8be /updater-ng
parentd4a1602762d07a1c03920c823f9ab1d81c431ca2 (diff)
downloadopenwrt-personal-pkgs-e0d55f0cfac63f4eea42203ab04364d9f47bc5ef.tar.gz
openwrt-personal-pkgs-e0d55f0cfac63f4eea42203ab04364d9f47bc5ef.tar.bz2
openwrt-personal-pkgs-e0d55f0cfac63f4eea42203ab04364d9f47bc5ef.zip
Revert "updater-ng: update to use autotools" and switch to future-66
This reverts commit d4a1602762d07a1c03920c823f9ab1d81c431ca2. This also moves target to future-66 branch.
Diffstat (limited to 'updater-ng')
-rw-r--r--updater-ng/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 6dd59b7..20645fd 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -9,17 +9,13 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=updater-ng
PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/updater.git
-PKG_SOURCE_BRANCH:=master
+PKG_SOURCE_BRANCH:=future-66
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
PKG_BUILD_DEPENDS:=busybox libb64 uthash argp-standalone
-PKG_INSTALL:=1
-PKG_FIXUP:=autoreconf
-
include $(INCLUDE_DIR)/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/autotools.mk
define Package/$(PKG_NAME)
TITLE:=The next generation updater
@@ -29,23 +25,18 @@ define Package/$(PKG_NAME)
+libevent2 \
+libcurl \
+liburiparser \
- +libarchive \
+ +libarchive \
+usign \
+ca-certificates
endef
-CONFIGURE_ARGS += \
- --disable-tests \
- --disable-linters \
- --disable-docs \
- --with-embed-busybox="$(STAGING_DIR)/bin/busybox-static"
-
define Package/$(PKG_NAME)/install
$(INSTALL_DIR) $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/lib/libupdater.so* $(1)/usr/lib/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/libupdater.so $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/* $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgupdate $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgtransaction $(1)/usr/bin/
$(INSTALL_BIN) ./files/update_alternatives.sh $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/updater
@@ -72,4 +63,13 @@ define Package/$(PKG_NAME)/conffiles
/etc/config/updater
endef
+
+define Build/Compile
+ $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) \
+ NO_DOC=1 LUA_COMPILE:=no \
+ BUSYBOX_EXEC=$(STAGING_DIR)/bin/busybox-static \
+ ARGP_STANDALONE=y \
+ UPDATER_VERSION:=$(PKG_VERSION)
+endef
+
$(eval $(call BuildPackage,$(PKG_NAME)))