summaryrefslogtreecommitdiff
path: root/updater-ng
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-06 14:11:53 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-06 14:11:53 +0200
commit595475d8f5bd6b6bc926a57e7b1c183bbb26ea0e (patch)
tree9cd82eb0522e57ef4790d8972b371b906003a238 /updater-ng
parentf199cf1563648ed0f750677b854c5388625aa719 (diff)
downloadopenwrt-personal-pkgs-595475d8f5bd6b6bc926a57e7b1c183bbb26ea0e.tar.gz
openwrt-personal-pkgs-595475d8f5bd6b6bc926a57e7b1c183bbb26ea0e.tar.bz2
openwrt-personal-pkgs-595475d8f5bd6b6bc926a57e7b1c183bbb26ea0e.zip
updater-ng: remove as latest version is now in HBK
Diffstat (limited to 'updater-ng')
-rw-r--r--updater-ng/Makefile79
-rw-r--r--updater-ng/files/turris.lua95
-rwxr-xr-xupdater-ng/files/update_alternatives.sh23
-rw-r--r--updater-ng/files/updater.config4
4 files changed, 0 insertions, 201 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
deleted file mode 100644
index 81a8e0b..0000000
--- a/updater-ng/Makefile
+++ /dev/null
@@ -1,79 +0,0 @@
-#
-## Copyright (C) 2016-2020 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=updater-ng
-PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/updater.git
-PKG_SOURCE_BRANCH:=master
-
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_LICENSE_FILES:=COPYING
-
-PKG_BUILD_DEPENDS:=busybox uthash argp-standalone
-
-PKG_INSTALL:=1
-PKG_FIXUP:=autoreconf
-
-include $(INCLUDE_DIR)/autopkg-branch.mk
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/autotools.mk
-
-define Package/updater-ng
- SECTION:=updater
- CATEGORY:=Turris Updater
- TITLE:=Updater
- DEPENDS:=\
- +liblua \
- +libuci-lua \
- +libevent2 \
- +libcurl \
- +liburiparser \
- +libarchive \
- +ca-certificates
-endef
-
-CONFIGURE_ARGS += \
- --disable-tests \
- --disable-linters \
- --disable-docs \
- --with-embed-busybox="$(STAGING_DIR)/bin/busybox-static"
-
-define Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libupdater.so* $(1)/usr/lib/
-
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
- $(INSTALL_BIN) ./files/update_alternatives.sh $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/etc/updater
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/conf.lua $(1)/etc/updater
- $(INSTALL_DIR) $(1)/etc/updater/conf.d
- $(INSTALL_CONF) ./files/turris.lua $(1)/etc/updater/conf.d/turris.lua
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/example.lua $(1)/etc/updater/conf.d/example.lua
-
- $(INSTALL_DIR) $(1)/etc/updater/hook_preupdate
- touch $(1)/etc/updater/hook_preupdate/.keep
- $(INSTALL_DIR) $(1)/etc/updater/hook_postupdate
- touch $(1)/etc/updater/hook_postupdate/.keep
- $(INSTALL_DIR) $(1)/etc/updater/hook_reboot_required
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_reboot_required/50-create-notification.sh $(1)/etc/updater/hook_reboot_required/50-create-notification.sh
-
- # Note: this file is not ever used as appropriate one is generated to medkit
- # it is here only for reference and to make sure that it exists.
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/updater.config $(1)/etc/config/updater
-endef
-
-define Package/updater-ng/conffiles
-/etc/updater/conf.d/example.lua
-/etc/config/updater
-endef
-
-$(eval $(call BuildPackage,updater-ng))
diff --git a/updater-ng/files/turris.lua b/updater-ng/files/turris.lua
deleted file mode 100644
index 97a7faf..0000000
--- a/updater-ng/files/turris.lua
+++ /dev/null
@@ -1,95 +0,0 @@
---[[
-This file is part of updater-ng. Don't edit it.
-]]
-
-local uci_cursor = nil
-if uci then
- uci_cursor = uci.cursor(root_dir .. "/etc/config")
-else
- ERROR("UCI library is not available. Configuration not used.")
-end
-local function uci_cnf(name, default)
- if uci_cursor then
- return uci_cursor:get("updater", "turris", name) or default
- else
- return default
- end
-end
-
--- Configuration variables
-local mode = uci_cnf("mode", "branch") -- should we follow branch or version?
-local branch = uci_cnf("branch", "hbs") -- which branch to follow
-local version = uci_cnf("version", nil) -- which version to follow
-local pkglists = uci_cnf("pkglists", {}) -- what additional lists should we use
-
--- Verify that we have sensible configuration
-if mode == "version" and not version then
- WARN("Mode configured to be 'version' but no version provided. Changing mode to 'branch' instead.")
- mode = "branch"
-end
-
--- Convert pkglists to set set of lists (ensures uniqueness)
-if type(pkglists) == "string" then -- if there is single list then uci returns just a string
- pkglists = {pkglists}
-end
-local lists = {}
-for _, list in pairs(pkglists) do
- lists["pkglists/" .. list] = true
-end
-
--- Load lists forced by boot arguments
-if root_dir == "/" then
- local cmdf = io.open("/proc/cmdline")
- if cmdf then
- for cmdarg in cmdf:read():gmatch('[^ ]+') do
- local key, value = cmdarg:match('([^=]+)=(.*)')
- if key == "turris_lists" then
- for list in value:gmatch('[^,]+') do
- lists[list] = true
- end
- end
- end
- cmdf:close()
- end
-end
-
--- Detect host board
-local product = os_release["OPENWRT_DEVICE_PRODUCT"] or os_release["LEDE_DEVICE_PRODUCT"]
-if product:match("[Mm]ox") then
- board = "mox"
-elseif product:match("[Oo]mnia") then
- board = "omnia"
-elseif product:match("[Tt]urris 1.x") then
- board = "turris1x"
-else
- DIE("Unsupported Turris board: " .. tostring(product))
-end
-Export('board')
-
--- Common URI to Turris OS lists
-local base_url
-if mode == "branch" then
- base_url = "https://repo.turris.cz/" .. branch .. "/" .. board .. "/lists/"
-elseif mode == "version" then
- base_url = "https://repo.turris.cz/archive/" .. version .. "/" .. board .. "/lists/"
-else
- DIE("Invalid updater.turris.mode specified: " .. mode)
-end
-
--- Common connection settings for Turris OS scripts
-local script_options = {
- security = "Remote",
- pubkey = {
- "file:///etc/updater/keys/release.pub",
- "file:///etc/updater/keys/standby.pub",
- "file:///etc/updater/keys/test.pub" -- It is normal for this one to not be present in production systems
- }
-}
-
--- The distribution base script. It contains the repository and bunch of basic packages
-Script(base_url .. "base.lua", script_options)
-
--- Additional enabled distribution lists
-for l in pairs(lists) do
- Script(base_url .. l .. ".lua", script_options)
-end
diff --git a/updater-ng/files/update_alternatives.sh b/updater-ng/files/update_alternatives.sh
deleted file mode 100755
index c93ae45..0000000
--- a/updater-ng/files/update_alternatives.sh
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-set -e
-
-if [ $# -gt 0 ]; then
- echo "This script is part of updater and allows user to manually fix alternative links in system." >&2
- exit 0
-fi
-
-if [ ! -d /usr/lib/opkg/info ]; then
- echo "OPKG info directory not located. This is OpenWrt system, isn't it?" >&2
- exit 1
-fi
-
-# Fist install all busybox applets and then overwite them with alternatives
-
-busybox --install /bin
-
-sed -n 's/^Alternatives://p' /usr/lib/opkg/info/*.control | \
- tr , '\n' | \
- sort -n | \
- while IFS=: read PRIO TRG SRC; do
- ln -sf "$SRC" "$TRG"
- done
diff --git a/updater-ng/files/updater.config b/updater-ng/files/updater.config
deleted file mode 100644
index 82e220e..0000000
--- a/updater-ng/files/updater.config
+++ /dev/null
@@ -1,4 +0,0 @@
-
-config turris 'turris'
- option mode 'branch'
-