summaryrefslogtreecommitdiff
path: root/updater-ng/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-03-10 12:56:43 +0100
committerKarel Kočí <karel.koci@nic.cz>2020-03-10 12:56:43 +0100
commitc0b53b2740725ea1f1b0b4d0193ed932d7295bfb (patch)
tree6cba1862a6526642948996c61e1ceab3b189a1e4 /updater-ng/Makefile
parentc26ee64f515bfcfef2ab5f85434e354251bbe18a (diff)
downloadopenwrt-personal-pkgs-c0b53b2740725ea1f1b0b4d0193ed932d7295bfb.tar.gz
openwrt-personal-pkgs-c0b53b2740725ea1f1b0b4d0193ed932d7295bfb.tar.bz2
openwrt-personal-pkgs-c0b53b2740725ea1f1b0b4d0193ed932d7295bfb.zip
updater-ng: add rolling version
Diffstat (limited to 'updater-ng/Makefile')
-rw-r--r--updater-ng/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
new file mode 100644
index 0000000..6a573ed
--- /dev/null
+++ b/updater-ng/Makefile
@@ -0,0 +1,75 @@
+#
+## Copyright (C) 2016-2020 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=updater-ng
+PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/updater.git
+PKG_SOURCE_BRANCH:=libarchive-unpack
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+
+PKG_BUILD_DEPENDS:=busybox libb64 uthash argp-standalone
+
+include $(INCLUDE_DIR)/autopkg-branch.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ TITLE:=The next generation updater
+ DEPENDS:=\
+ +liblua \
+ +libuci-lua \
+ +libevent2 \
+ +libcurl \
+ +liburiparser \
+ +libarchive \
+ +usign \
+ +ca-certificates
+endef
+
+define Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/libupdater.so $(1)/usr/lib/
+
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgupdate $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgtransaction $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/update_alternatives.sh $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/updater
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/conf.lua $(1)/etc/updater
+ $(INSTALL_DIR) $(1)/etc/updater/conf.d
+ $(INSTALL_CONF) ./files/turris.lua $(1)/etc/updater/conf.d/turris.lua
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/example.lua $(1)/etc/updater/conf.d/example.lua
+
+ $(INSTALL_DIR) $(1)/etc/updater/hook_preupdate
+ touch $(1)/etc/updater/hook_preupdate/.keep
+ $(INSTALL_DIR) $(1)/etc/updater/hook_postupdate
+ touch $(1)/etc/updater/hook_postupdate/.keep
+ $(INSTALL_DIR) $(1)/etc/updater/hook_reboot_required
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_reboot_required/50-create-notification.sh $(1)/etc/updater/hook_reboot_required/50-create-notification.sh
+
+ # Note: this file is not ever used as appropriate one is generated to medkit
+ # it is here only for reference and to make sure that it exists.
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/updater.config $(1)/etc/config/updater
+endef
+
+define Package/$(PKG_NAME)/conffiles
+/etc/updater/conf.d/example.lua
+/etc/config/updater
+endef
+
+
+define Build/Compile
+ $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) \
+ NO_DOC=1 LUA_COMPILE:=no \
+ BUSYBOX_EXEC=$(STAGING_DIR)/bin/busybox-static \
+ ARGP_STANDALONE=y \
+ UPDATER_VERSION:=$(PKG_VERSION)
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))