summaryrefslogtreecommitdiff
path: root/updater-ng/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-05-18 17:46:00 +0200
committerKarel Kočí <cynerd@email.cz>2020-05-18 17:46:00 +0200
commit661bf2db1f84ed0b2098037d27181f95ba1f6ff2 (patch)
tree1b734a6f51262cd8db0216eb198ba9dcf8e3f8fc /updater-ng/Makefile
parente0d55f0cfac63f4eea42203ab04364d9f47bc5ef (diff)
downloadopenwrt-personal-pkgs-661bf2db1f84ed0b2098037d27181f95ba1f6ff2.tar.gz
openwrt-personal-pkgs-661bf2db1f84ed0b2098037d27181f95ba1f6ff2.tar.bz2
openwrt-personal-pkgs-661bf2db1f84ed0b2098037d27181f95ba1f6ff2.zip
Revert "Revert "updater-ng: update to use autotools" and switch to future-66"
This reverts commit e0d55f0cfac63f4eea42203ab04364d9f47bc5ef.
Diffstat (limited to 'updater-ng/Makefile')
-rw-r--r--updater-ng/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 20645fd..6dd59b7 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -9,13 +9,17 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=updater-ng
PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/updater.git
-PKG_SOURCE_BRANCH:=future-66
+PKG_SOURCE_BRANCH:=master
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
PKG_BUILD_DEPENDS:=busybox libb64 uthash argp-standalone
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
include $(INCLUDE_DIR)/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/autotools.mk
define Package/$(PKG_NAME)
TITLE:=The next generation updater
@@ -25,18 +29,23 @@ define Package/$(PKG_NAME)
+libevent2 \
+libcurl \
+liburiparser \
- +libarchive \
+ +libarchive \
+usign \
+ca-certificates
endef
+CONFIGURE_ARGS += \
+ --disable-tests \
+ --disable-linters \
+ --disable-docs \
+ --with-embed-busybox="$(STAGING_DIR)/bin/busybox-static"
+
define Package/$(PKG_NAME)/install
$(INSTALL_DIR) $(1)/usr/lib/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/libupdater.so $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/lib/libupdater.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgupdate $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgtransaction $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/* $(1)/usr/bin/
$(INSTALL_BIN) ./files/update_alternatives.sh $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/updater
@@ -63,13 +72,4 @@ define Package/$(PKG_NAME)/conffiles
/etc/config/updater
endef
-
-define Build/Compile
- $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) \
- NO_DOC=1 LUA_COMPILE:=no \
- BUSYBOX_EXEC=$(STAGING_DIR)/bin/busybox-static \
- ARGP_STANDALONE=y \
- UPDATER_VERSION:=$(PKG_VERSION)
-endef
-
$(eval $(call BuildPackage,$(PKG_NAME)))