summaryrefslogtreecommitdiff
path: root/updater-ng/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-10-10 11:18:29 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-10-10 11:19:33 +0200
commit5e854bd1fa80130b58f5cde9595929166b0178eb (patch)
treef5f4a1f6882e4dfc204af49b1ab0aa43af1b4d30 /updater-ng/Makefile
parente80d577eca049b4968d30c77ab646fa4fcd01780 (diff)
parent22ca6212993dec46c1b32df68f91db59ff46605c (diff)
downloadopenwrt-personal-pkgs-5e854bd1fa80130b58f5cde9595929166b0178eb.tar.gz
openwrt-personal-pkgs-5e854bd1fa80130b58f5cde9595929166b0178eb.tar.bz2
openwrt-personal-pkgs-5e854bd1fa80130b58f5cde9595929166b0178eb.zip
Merge branch 'turris3x'
Diffstat (limited to 'updater-ng/Makefile')
-rw-r--r--updater-ng/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 56967b6..3dcbe66 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -32,12 +32,12 @@ define Package/$(PKG_NAME)/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/opkg-trans $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgupdate $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/supervisor/updater.sh $(1)/usr/bin/
- $(INSTALL_BIN) .//files/updater-wipe.sh $(1)/usr/bin/
+ $(INSTALL_BIN) ./files/updater-wipe.sh $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/updater
$(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/conf.lua $(1)/etc/updater
$(INSTALL_DIR) $(1)/etc/updater/conf.d
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/base.lua $(1)/etc/updater/conf.d/base.lua
+ $(INSTALL_CONF) ./files/turris.lua $(1)/etc/updater/conf.d/turris.lua
$(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/example.lua $(1)/etc/updater/conf.d/example.lua
$(INSTALL_DIR) $(1)/etc/updater/hook_preupdate
@@ -49,11 +49,6 @@ define Package/$(PKG_NAME)/install
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) ./files/updater.config $(1)/etc/config/updater
-ifneq ($(PKG_BRANCH),)
- echo >> $(1)/etc/config/updater
- echo "config override 'override'" >> $(1)/etc/config/updater
- echo " option branch '$(PKG_BRANCH)'" >> $(1)/etc/config/updater
-endif
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/init $(1)/etc/init.d/updater
@@ -115,7 +110,7 @@ endef
define Package/$(PKG_NAME)-supervisor
- TITLE:=Next generation updater supervisor and its library
+ TITLE:=Next generation updater supervisor and it's library
DEPENDS:=+updater-ng +vixie-cron +python3-light +python3-uci +userlists +l10n_supported
EXTRA_DEPENDS:=userlists (>=11)
endef