summaryrefslogtreecommitdiff
path: root/updater-ng/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-06-23 15:18:31 +0200
committerKarel Kočí <karel.koci@nic.cz>2020-06-23 15:18:31 +0200
commit52f689f9d63615f87c965370aa93cfc3db10229f (patch)
tree14c34b0ab3e4caa380ec9ed405485760912d71e4 /updater-ng/Makefile
parente13f0e62373c9521316e799ed39ab25ce0ab71d0 (diff)
downloadopenwrt-personal-pkgs-52f689f9d63615f87c965370aa93cfc3db10229f.tar.gz
openwrt-personal-pkgs-52f689f9d63615f87c965370aa93cfc3db10229f.tar.bz2
openwrt-personal-pkgs-52f689f9d63615f87c965370aa93cfc3db10229f.zip
updater-ng: sync version with the one in turris-os-packages
Diffstat (limited to 'updater-ng/Makefile')
-rw-r--r--updater-ng/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index 4334f8a..ed05467 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -10,7 +10,10 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=updater-ng
PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/updater.git
PKG_SOURCE_BRANCH:=hotfix-sign
+
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING
PKG_BUILD_DEPENDS:=busybox uthash argp-standalone
@@ -21,8 +24,10 @@ include $(INCLUDE_DIR)/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/autotools.mk
-define Package/$(PKG_NAME)
- TITLE:=The next generation updater
+define Package/updater-ng
+ SECTION:=updater
+ CATEGORY:=Turris Updater
+ TITLE:=Updater
DEPENDS:=\
+liblua \
+libuci-lua \
@@ -30,7 +35,6 @@ define Package/$(PKG_NAME)
+libcurl \
+liburiparser \
+libarchive \
- +usign \
+ca-certificates
endef
@@ -67,9 +71,9 @@ define Package/$(PKG_NAME)/install
$(INSTALL_CONF) ./files/updater.config $(1)/etc/config/updater
endef
-define Package/$(PKG_NAME)/conffiles
+define Package/updater-ng/conffiles
/etc/updater/conf.d/example.lua
/etc/config/updater
endef
-$(eval $(call BuildPackage,$(PKG_NAME)))
+$(eval $(call BuildPackage,updater-ng))