summaryrefslogtreecommitdiff
path: root/updater-ng/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-06-18 14:14:08 +0200
committerKarel Kočí <karel.koci@nic.cz>2019-06-18 14:14:08 +0200
commit2e3e616bf96c08083cde8748c04f2e6d2ed263e1 (patch)
tree1469c53d3b4676e56caacc37f2514b67c21f45b4 /updater-ng/Makefile
parent63bdb87a3a269ed0c5cb7fdfb8b9c0a8e4ae76bf (diff)
downloadopenwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.tar.gz
openwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.tar.bz2
openwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.zip
Drop rolling updater for now
Diffstat (limited to 'updater-ng/Makefile')
-rw-r--r--updater-ng/Makefile97
1 files changed, 0 insertions, 97 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
deleted file mode 100644
index a621c9c..0000000
--- a/updater-ng/Makefile
+++ /dev/null
@@ -1,97 +0,0 @@
-#
-## Copyright (C) 2016-2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=updater-ng
-PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/updater.git
-PKG_SOURCE_BRANCH:=master
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-
-HOST_BUILD_DEPENDS:= \
- curl/host \
- libevent2/host \
- lua/host \
- uriparser/host \
- libb64/host \
- uthash/host
-PKG_BUILD_DEPENDS:=busybox libb64 uthash argp-standalone
-
-include $(INCLUDE_DIR)/autopkg-branch.mk
-include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/$(PKG_NAME)
- TITLE:=The next generation updater
- DEPENDS:=\
- +liblua \
- +libuci-lua \
- +libevent2 \
- +libcurl \
- +liburiparser \
- +usign \
- +ca-certificates
-endef
-
-define Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/lib/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/libupdater.so $(1)/usr/lib/
-
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgupdate $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/pkgtransaction $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/etc/updater
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/conf.lua $(1)/etc/updater
- $(INSTALL_DIR) $(1)/etc/updater/conf.d
- $(INSTALL_CONF) ./files/turris.lua $(1)/etc/updater/conf.d/turris.lua
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/pkgupdate/configs/example.lua $(1)/etc/updater/conf.d/example.lua
-
- $(INSTALL_DIR) $(1)/etc/updater/hook_preupdate
- touch $(1)/etc/updater/hook_preupdate/.keep
- $(INSTALL_DIR) $(1)/etc/updater/hook_postupdate
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_postupdate/update_alternatives.sh $(1)/etc/updater/hook_postupdate/20_update_alternatives.sh
- $(INSTALL_DIR) $(1)/etc/updater/hook_reboot_required
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_reboot_required/50-create-notification.sh $(1)/etc/updater/hook_reboot_required/50-create-notification.sh
-
- # Note: this file is not ever used as appropriate one is generated to medkit
- # it is here only for reference and to make sure that it exists.
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/updater.config $(1)/etc/config/updater
-endef
-
-define Package/$(PKG_NAME)/conffiles
-/etc/updater/conf.d/example.lua
-/etc/config/updater
-endef
-
-
-define Build/Compile
- $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) \
- NO_DOC=1 LUA_COMPILE:=no \
- BUSYBOX_EXEC=$(STAGING_DIR)/bin/busybox-static \
- ARGP_STANDALONE=y \
- UPDATER_VERSION:=$(PKG_VERSION)
-endef
-
-define Host/Compile
- $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) $(HOST_MAKE_FLAGS) \
- NO_DOC=1 LUA_COMPILE:=no \
- UPDATER_VERSION:=$(PKG_VERSION)
-endef
-
-define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/usr/lib/
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/lib/libupdater.so $(STAGING_DIR_HOST)/usr/lib/
-
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/usr/bin
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/pkgupdate $(STAGING_DIR_HOST)/usr/bin/
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/pkgtransaction $(STAGING_DIR_HOST)/usr/bin/
-endef
-
-$(eval $(call HostBuild))
-$(eval $(call BuildPackage,$(PKG_NAME)))