summaryrefslogtreecommitdiff
path: root/shellrc
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-24 18:34:27 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-24 18:38:36 +0200
commit0b257e6041a9baab6a0030d70d3a626648aa0608 (patch)
tree672001f2287f30d82aee62277937f2326715d6ec /shellrc
parent041418da93ee5c4711f5cff53d0c419ae4654765 (diff)
downloadopenwrt-personal-pkgs-0b257e6041a9baab6a0030d70d3a626648aa0608.tar.gz
openwrt-personal-pkgs-0b257e6041a9baab6a0030d70d3a626648aa0608.tar.bz2
openwrt-personal-pkgs-0b257e6041a9baab6a0030d70d3a626648aa0608.zip
Add shellrc package
Diffstat (limited to 'shellrc')
-rw-r--r--shellrc/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/shellrc/Makefile b/shellrc/Makefile
new file mode 100644
index 0000000..628dd9f
--- /dev/null
+++ b/shellrc/Makefile
@@ -0,0 +1,58 @@
+#
+## Copyright (C) 2018 Karel Kočí
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=shellrc
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=https://git.cynerd.cz/shellrc
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+$(call include_mk, autopkg-tag.mk)
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ TITLE:=Shell initialization files
+endef
+
+define Package/$(PKG_NAME)-bash
+ TITLE:=Shell initialization files bash specific
+ DEPENDS:=$(PKG_NAME) bash
+endef
+
+define Package/$(PKG_NAME)-zsh
+ TITLE:=Shell initialization files zsh specific
+ DEPENDS:=$(PKG_NAME) zsh
+endef
+
+define Package/$(PKG_NAME)-ash
+ TITLE:=Shell initialization files ash specific
+ DEPENDS:=$(PKG_NAME)
+endef
+
+define Build/Compile
+ true
+endef
+
+define Package/$(PKG_NAME)/install
+ $(PKG_BUILD_DIR)/install --prefix "$(1)"
+endef
+
+define Package/$(PKG_NAME)-bash/install
+ $(PKG_BUILD_DIR)/install --prefix "$(1)" --bash --no-base
+endef
+
+define Package/$(PKG_NAME)-zsh/install
+ $(PKG_BUILD_DIR)/install --prefix "$(1)" --zsh --no-base
+endef
+
+define Package/$(PKG_NAME)-ash/install
+ # TODO
+ #$(PKG_BUILD_DIR)/install --prefix "$(1)" --ash --no-base
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))