summaryrefslogtreecommitdiff
path: root/sentinel-proxy/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-12-09 12:51:50 +0100
committerKarel Kočí <cynerd@email.cz>2021-12-09 12:51:50 +0100
commit45c300126e4a1f72eba94791f8da27e7082c2ec6 (patch)
tree338afb0530a7bd87e0b99937eee510fcb7540228 /sentinel-proxy/Makefile
parent3df1aad296a94639ac36d3da87d52c27a26053a8 (diff)
downloadopenwrt-personal-pkgs-45c300126e4a1f72eba94791f8da27e7082c2ec6.tar.gz
openwrt-personal-pkgs-45c300126e4a1f72eba94791f8da27e7082c2ec6.tar.bz2
openwrt-personal-pkgs-45c300126e4a1f72eba94791f8da27e7082c2ec6.zip
sentinel-proxy: remove testing version
Diffstat (limited to 'sentinel-proxy/Makefile')
-rw-r--r--sentinel-proxy/Makefile89
1 files changed, 0 insertions, 89 deletions
diff --git a/sentinel-proxy/Makefile b/sentinel-proxy/Makefile
deleted file mode 100644
index d02ab42..0000000
--- a/sentinel-proxy/Makefile
+++ /dev/null
@@ -1,89 +0,0 @@
-#
-## Copyright (C) 2018-2020 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=sentinel-proxy
-#PKG_VERSION:=1.3
-#PKG_RELEASE:=7
-
-#PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/sentinel/proxy.git
-PKG_SOURCE_BRANCH:=hotfix/mqtt
-#PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-PKG_LICENSE:=GPL-3.0-or-later
-
-PKG_FIXUP:=autoreconf
-
-PKG_BUILD_DEPENDS:=argp-standalone
-
-include $(INCLUDE_DIR)/autopkg-branch.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/sentinel-proxy
- SECTION:=collect
- CATEGORY:=Collect
- SUBMENU:=Sentinel
- TITLE:=Proxy
- URL:=https://gitlab.nic.cz/turris/sentinel/proxy
- DEPENDS:= \
- +czmq \
- +libpaho-mqtt-c \
- +zlib \
- +libopenssl \
- +libconfig \
- +sentinel-certgen \
- +sentinel-eula
-endef
-
-define Package/sentinel-proxy/description
- Central daemon proxying all Sentinel trafic on router to Turris servers.
-endef
-
-define Package/sentinel-proxy/install
- $(INSTALL_DIR) $(1)/lib/functions/
- $(INSTALL_CONF) ./files/sentinel.sh $(1)/lib/functions/sentinel.sh
-
- $(INSTALL_DIR) $(1)/etc/sentinel
- $(INSTALL_DATA) ./files/ca.pem $(1)/etc/sentinel/ca.pem
-
- $(INSTALL_DIR) $(1)/usr/lib/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/libsentinel-device-token.so.1.0.0 $(1)/usr/lib/libsentinel-device-token.so.1
-
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/sentinel-proxy $(1)/usr/bin/sentinel-proxy
-
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/sentinel-device-token $(1)/usr/bin/sentinel-device-token
-
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/init $(1)/etc/init.d/sentinel-proxy
-
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_BIN) ./files/uci $(1)/etc/config/sentinel
-
- $(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_BIN) ./files/uci-defaults $(1)/etc/uci-defaults/99-sentinel-main
-
- $(INSTALL_BIN) ./files/sentinel-reload.sh $(1)/usr/bin/sentinel-reload
-
- $(INSTALL_DIR) $(1)/usr/libexec/sentinel/renew_hooks.d
- $(INSTALL_BIN) ./files/restart-proxy-hook.sh $(1)/usr/libexec/sentinel/renew_hooks.d/50_proxy_restart.sh
-
- $(INSTALL_DIR) $(1)/usr/libexec/sentinel/reload_hooks.d
- $(INSTALL_BIN) ./files/restart-proxy-hook.sh $(1)/usr/libexec/sentinel/reload_hooks.d/50_proxy.sh
-
- $(INSTALL_DIR) $(1)/etc/cron.d
- $(INSTALL_DATA) ./files/renew.cron $(1)/etc/cron.d/certgen-certs-renew
-endef
-
-define Package/sentinel-proxy/conffiles
-/etc/config/sentinel
-endef
-
-$(eval $(call BuildPackage,sentinel-proxy))