summaryrefslogtreecommitdiff
path: root/sentinel-minipot
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-12 15:01:08 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-12 15:01:47 +0200
commit0ae9d9c4b9fee821b68b2d3bc700c9324a50a107 (patch)
treea130f8e78f8903209a0fabc2cfc7872e17e56fed /sentinel-minipot
parent27efe998eb65db87a5171da6795142143cd79116 (diff)
downloadopenwrt-personal-pkgs-0ae9d9c4b9fee821b68b2d3bc700c9324a50a107.tar.gz
openwrt-personal-pkgs-0ae9d9c4b9fee821b68b2d3bc700c9324a50a107.tar.bz2
openwrt-personal-pkgs-0ae9d9c4b9fee821b68b2d3bc700c9324a50a107.zip
sentinel-minipot: also provide port 25 (not only SMTP submission)
Diffstat (limited to 'sentinel-minipot')
-rw-r--r--sentinel-minipot/Makefile2
-rw-r--r--sentinel-minipot/files/sentinel-firewall.sh8
2 files changed, 7 insertions, 3 deletions
diff --git a/sentinel-minipot/Makefile b/sentinel-minipot/Makefile
index d63a4b0..d210e9a 100644
--- a/sentinel-minipot/Makefile
+++ b/sentinel-minipot/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sentinel-minipot
PKG_VERSION:=2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/sentinel/minipot.git
PKG_SOURCE_VERSION:=7daf3f92cf47b4aaf65e27f597aa8d9be35f4c90
diff --git a/sentinel-minipot/files/sentinel-firewall.sh b/sentinel-minipot/files/sentinel-firewall.sh
index 40c584b..e4a69b1 100644
--- a/sentinel-minipot/files/sentinel-firewall.sh
+++ b/sentinel-minipot/files/sentinel-firewall.sh
@@ -27,8 +27,10 @@ port_redirect_zone() {
iptables_redirect "$zone" 21 "$ftp_port" "Minipot FTP"
[ "$http_port" = "0" ] || \
iptables_redirect "$zone" 80 "$http_port" "Minipot HTTP"
- [ "$smtp_port" = "0" ] || \
+ [ "$smtp_port" = "0" ] || {
+ iptables_redirect "$zone" 25 "$smtp_port" "Minipot SMTP"
iptables_redirect "$zone" 587 "$smtp_port" "Minipot SMTP submission"
+ }
[ "$telnet_port" = "0" ] || \
iptables_redirect "$zone" 23 "$telnet_port" "Minipot Telnet"
}
@@ -42,8 +44,10 @@ if source_if_exists "$SF_DIR/dynfw-utils.sh"; then
bypass_dynamic_firewall "tcp" "21" "Minipot FTP"
[ "$http_port" = "0" ] || \
bypass_dynamic_firewall "tcp" "23" "Minipot HTTP"
- [ "$smtp_port" = "0" ] || \
+ [ "$smtp_port" = "0" ] || {
+ bypass_dynamic_firewall "tcp" "25" "Minipot SMTP"
bypass_dynamic_firewall "tcp" "587" "Minipot SMTP submission"
+ }
[ "$telnet_port" = "0" ] || \
bypass_dynamic_firewall "tcp" "23" "Minipot Telnet"
fi