summaryrefslogtreecommitdiff
path: root/sentinel-minipot/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-11 16:06:59 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-11 16:06:59 +0200
commit09fb4b7b9651a35e13a95d2da6e21d230bfebb34 (patch)
treed2379de111f3d835ce356b5e9f5f7fa4cca0eddb /sentinel-minipot/Makefile
parent2f31048b9123444aed7559b72c56645d73379e4b (diff)
downloadopenwrt-personal-pkgs-09fb4b7b9651a35e13a95d2da6e21d230bfebb34.tar.gz
openwrt-personal-pkgs-09fb4b7b9651a35e13a95d2da6e21d230bfebb34.tar.bz2
openwrt-personal-pkgs-09fb4b7b9651a35e13a95d2da6e21d230bfebb34.zip
sentinel-minipot: include additional minipots
Diffstat (limited to 'sentinel-minipot/Makefile')
-rw-r--r--sentinel-minipot/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/sentinel-minipot/Makefile b/sentinel-minipot/Makefile
index 2db0833..6ac8e95 100644
--- a/sentinel-minipot/Makefile
+++ b/sentinel-minipot/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sentinel-minipot
-PKG_VERSION:=1
-PKG_RELEASE:=10
+PKG_VERSION:=2.0
+PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/sentinel/minipot.git
-PKG_SOURCE_VERSION:=ebc6c8f96202b6c122fcc8f94b9413ec6bfd2e4f
+PKG_SOURCE_VERSION:=cf5a115c6b064ad510c2a6fff255f96e36fa63e4
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
PKG_LICENSE:=GPL-3.0-or-later
@@ -36,19 +36,23 @@ define Package/sentinel-minipot
endef
define Package/sentinel-minipot/description
- Sentinel minipots. These are minimal honeypots. Implements protocols: telnet
+ Sentinel minipots. These are minimal honeypots.
+ Implements protocols: FTP, HTTP, SMTP submission and Telnet
endef
define Package/sentinel-minipot/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/sentinel_minipot $(1)/usr/bin/sentinel-minipot
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/sentinel-minipot $(1)/usr/bin/sentinel-minipot
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/init $(1)/etc/init.d/sentinel-minipot
+
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/uci-defaults $(1)/etc/uci-defaults/99-sentinel-minipot-telnet
+
$(INSTALL_DIR) $(1)/usr/libexec/sentinel/firewall.d
$(INSTALL_BIN) ./files/sentinel-firewall.sh $(1)/usr/libexec/sentinel/firewall.d/70-minipot.sh
+ $(INSTALL_DATA) ./files/defaults.sh $(1)/usr/libexec/sentinel/minipot-defaults.sh
$(INSTALL_DIR) $(1)/usr/libexec/sentinel/reload_hooks.d
$(INSTALL_BIN) ./files/restart-minipot-hook.sh $(1)/usr/libexec/sentinel/reload_hooks.d/60_minipot.sh