summaryrefslogtreecommitdiff
path: root/sentinel-fwlogs/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-11-05 11:08:59 +0100
committerKarel Kočí <cynerd@email.cz>2020-11-05 11:08:59 +0100
commit59cbf758e1965f7127e337983a4f3e38f8233e4d (patch)
tree213424910c603e85788518d9ec6b34de00623225 /sentinel-fwlogs/Makefile
parent9aa4f21cf22502060841830300d5d02907e3f5a4 (diff)
downloadopenwrt-personal-pkgs-59cbf758e1965f7127e337983a4f3e38f8233e4d.tar.gz
openwrt-personal-pkgs-59cbf758e1965f7127e337983a4f3e38f8233e4d.tar.bz2
openwrt-personal-pkgs-59cbf758e1965f7127e337983a4f3e38f8233e4d.zip
Remove packages merged to turris-os-packages
Diffstat (limited to 'sentinel-fwlogs/Makefile')
-rw-r--r--sentinel-fwlogs/Makefile69
1 files changed, 0 insertions, 69 deletions
diff --git a/sentinel-fwlogs/Makefile b/sentinel-fwlogs/Makefile
deleted file mode 100644
index 32874a9..0000000
--- a/sentinel-fwlogs/Makefile
+++ /dev/null
@@ -1,69 +0,0 @@
-#
-## Copyright (C) 2020 CZ.NIC z.s.p.o. (https://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v3.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=sentinel-fwlogs
-PKG_VERSION:=0.0.1
-PKG_RELEASE:=4
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/sentinel/fwlogs.git
-#PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_SOURCE_VERSION:=2b4d3924d213696cb93d2e2690a84b947ff187df
-
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_LICENSE_FILES:=LICENSE
-
-PKG_BUILD_DEPENDS:=argp-standalone
-
-PKG_INSTALL:=1
-PKG_FIXUP:=autoreconf
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/sentinel-fwlogs
- SECTION:=collect
- CATEGORY:=Collect
- SUBMENU:=Sentinel
- TITLE:=FWLogs
- URL:=https://gitlab.nic.cz/turris/sentinel/fwlogs
- DEPENDS:=\
- +czmq \
- +msgpack-c \
- +logc +logc-argp \
- +libnetfilter-log \
- +sentinel-firewall +iptables-mod-nflog \
- +sentinel-proxy
- PROVIDES:=sentinel-nikola
- CONFLICTS:=sentinel-nikola
-endef
-
-define Package/sentinel-fwlogs/description
- Collector of firewall logs using libnetfilter-log for Turris Sentinel.
-endef
-
-define Package/sentinel-fwlogs/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/sentinel-fwlogs $(1)/usr/bin/sentinel-fwlogs
-
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/init $(1)/etc/init.d/sentinel-fwlogs
-
- $(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_BIN) ./files/uci-defaults $(1)/etc/uci-defaults/99-sentinel-fwlogs
-
- $(INSTALL_DIR) $(1)/usr/libexec/sentinel/firewall.d
- $(INSTALL_BIN) ./files/sentinel-firewall.sh $(1)/usr/libexec/sentinel/firewall.d/60-fwlogs.sh
- $(INSTALL_DATA) ./files/defaults.sh $(1)/usr/libexec/sentinel/fwlogs-defaults.sh
-
- $(INSTALL_DIR) $(1)/usr/libexec/sentinel/reload_hooks.d
- $(INSTALL_BIN) ./files/restart-proxy-hook.sh $(1)/usr/libexec/sentinel/reload_hooks.d/50_nikola.sh
-endef
-
-$(eval $(call BuildPackage,sentinel-fwlogs))