summaryrefslogtreecommitdiff
path: root/python3-requests/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-10-09 09:59:52 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-10-09 10:00:59 +0200
commite80d577eca049b4968d30c77ab646fa4fcd01780 (patch)
treeaf48600c83613401d7c8be7c7f6db5f616ce68af /python3-requests/Makefile
parent3532fa47380fb79d6c6edb32039c1b491f64709a (diff)
parentd32f4c85ac3634a3a4c35d4fec7dc8131c9cfcab (diff)
downloadopenwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.tar.gz
openwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.tar.bz2
openwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.zip
Merge branch 'turris3x'
Diffstat (limited to 'python3-requests/Makefile')
-rw-r--r--python3-requests/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/python3-requests/Makefile b/python3-requests/Makefile
new file mode 100644
index 0000000..f7a97ee
--- /dev/null
+++ b/python3-requests/Makefile
@@ -0,0 +1,38 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-requests
+PKG_VERSION:=2.19.1
+PKG_RELEASE:=2
+
+PKG_SOURCE:=requests-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/r/requests/
+PKG_MD5SUM:=6c1a31afec9d614e2e71a91ee6ca2878
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/requests-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=python3-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/python3-requests
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Python HTTP for Humans.
+ URL:=http://python-requests.org
+ DEPENDS:=+python3 +python3-chardet +python3-idna +python3-urllib3 +python3-certifi
+endef
+
+define Package/python3-requests/description
+ Python HTTP for Humans.
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,, \
+ install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
+ --single-version-externally-managed \
+ )
+endef
+
+$(eval $(call Py3Package,python3-requests))
+$(eval $(call BuildPackage,python3-requests))