summaryrefslogtreecommitdiff
path: root/python3-dateutil/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-02-04 14:24:08 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-02-04 14:24:08 +0100
commitee1de2a3d1376e1aa19cc4deaaece86b32ab14aa (patch)
tree776190b57b72e62a0eb0ba751aa08ff50e9f21e7 /python3-dateutil/Makefile
parent647f5119e89ef2d67f270a954e38633badab1621 (diff)
downloadopenwrt-personal-pkgs-ee1de2a3d1376e1aa19cc4deaaece86b32ab14aa.tar.gz
openwrt-personal-pkgs-ee1de2a3d1376e1aa19cc4deaaece86b32ab14aa.tar.bz2
openwrt-personal-pkgs-ee1de2a3d1376e1aa19cc4deaaece86b32ab14aa.zip
Drop bigclown because I am pushing it upstream
Diffstat (limited to 'python3-dateutil/Makefile')
-rw-r--r--python3-dateutil/Makefile37
1 files changed, 0 insertions, 37 deletions
diff --git a/python3-dateutil/Makefile b/python3-dateutil/Makefile
deleted file mode 100644
index 357590f..0000000
--- a/python3-dateutil/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python3-dateutil
-PKG_VERSION:=2.7.3
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/python-dateutil/
-PKG_SOURCE:=python-dateutil-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=175b7c1a3cc0cb01151eced07c61c0b8
-PKG_BUILD_DIR:=$(BUILD_DIR)/python-dateutil-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=python3-setuptools
-
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/$(PKG_NAME)
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Python powerful extensions to datetime
- URL:=https://dateutil.readthedocs.io/en/stable/
- DEPENDS:=+python3 +python3-six
-endef
-
-define Package/$(PKG_NAME)/description
- Python powerful extensions to datetime
-endef
-
-define Build/Compile
- $(call Build/Compile/Py3Mod,, \
- install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
- --single-version-externally-managed \
- )
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))