summaryrefslogtreecommitdiff
path: root/python3-dateutil/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-10-09 09:59:52 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-10-09 10:00:59 +0200
commite80d577eca049b4968d30c77ab646fa4fcd01780 (patch)
treeaf48600c83613401d7c8be7c7f6db5f616ce68af /python3-dateutil/Makefile
parent3532fa47380fb79d6c6edb32039c1b491f64709a (diff)
parentd32f4c85ac3634a3a4c35d4fec7dc8131c9cfcab (diff)
downloadopenwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.tar.gz
openwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.tar.bz2
openwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.zip
Merge branch 'turris3x'
Diffstat (limited to 'python3-dateutil/Makefile')
-rw-r--r--python3-dateutil/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/python3-dateutil/Makefile b/python3-dateutil/Makefile
new file mode 100644
index 0000000..357590f
--- /dev/null
+++ b/python3-dateutil/Makefile
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-dateutil
+PKG_VERSION:=2.7.3
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/python-dateutil/
+PKG_SOURCE:=python-dateutil-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=175b7c1a3cc0cb01151eced07c61c0b8
+PKG_BUILD_DIR:=$(BUILD_DIR)/python-dateutil-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=python3-setuptools
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Python powerful extensions to datetime
+ URL:=https://dateutil.readthedocs.io/en/stable/
+ DEPENDS:=+python3 +python3-six
+endef
+
+define Package/$(PKG_NAME)/description
+ Python powerful extensions to datetime
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,, \
+ install --root="$(PKG_INSTALL_DIR)" --prefix="/usr" \
+ --single-version-externally-managed \
+ )
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))