summaryrefslogtreecommitdiff
path: root/python3-certifi/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-10-09 09:59:52 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-10-09 10:00:59 +0200
commite80d577eca049b4968d30c77ab646fa4fcd01780 (patch)
treeaf48600c83613401d7c8be7c7f6db5f616ce68af /python3-certifi/Makefile
parent3532fa47380fb79d6c6edb32039c1b491f64709a (diff)
parentd32f4c85ac3634a3a4c35d4fec7dc8131c9cfcab (diff)
downloadopenwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.tar.gz
openwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.tar.bz2
openwrt-personal-pkgs-e80d577eca049b4968d30c77ab646fa4fcd01780.zip
Merge branch 'turris3x'
Diffstat (limited to 'python3-certifi/Makefile')
-rw-r--r--python3-certifi/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/python3-certifi/Makefile b/python3-certifi/Makefile
new file mode 100644
index 0000000..e51f02f
--- /dev/null
+++ b/python3-certifi/Makefile
@@ -0,0 +1,26 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-certifi
+PKG_VERSION:=2018.8.24
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/certifi/
+PKG_SOURCE:=certifi-$(PKG_VERSION).tar.gz
+PKG_MDSUM:=c6be18cddd339c893131d992e13949c1
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/certifi-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=Collection of Root Certificates for validating the trustworthiness of SSL certificates
+ DEPENDS:=+python3
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))