summaryrefslogtreecommitdiff
path: root/python-rich
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-02-15 13:29:19 +0100
committerKarel Kočí <cynerd@email.cz>2022-02-15 13:29:19 +0100
commitadf136e41c30971c523088ea71b46f11a616939d (patch)
treea17882162f09a2aa6ee97e9b83911f2394514739 /python-rich
parent0ed3e2856a5700363e72c9bdfc993d453d409764 (diff)
downloadopenwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.tar.gz
openwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.tar.bz2
openwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.zip
healthcheck: add to test the development version
Diffstat (limited to 'python-rich')
-rw-r--r--python-rich/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/python-rich/Makefile b/python-rich/Makefile
new file mode 100644
index 0000000..924eae2
--- /dev/null
+++ b/python-rich/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-rich
+PKG_VERSION:=10.15.2
+PKG_RELEASE:=1
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=rich
+PKG_HASH:=1dded089b79dd042b3ab5cd63439a338e16652001f0c16e73acdcf4997ad772d
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-rich
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Render rich text and more to the terminal
+ URL:=https://github.com/willmcgugan/rich
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-rich/description
+ Render rich text, tables, progress bars, syntax highlighting, markdown and more
+ to the terminal.
+endef
+
+$(eval $(call Py3Package,python3-rich))
+$(eval $(call BuildPackage,python3-rich))
+$(eval $(call BuildPackage,python3-rich-src))