summaryrefslogtreecommitdiff
path: root/python-jsonpath-ng/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-02-10 16:06:31 +0100
committerKarel Kočí <cynerd@email.cz>2019-02-10 16:06:31 +0100
commit5f7b7084a81813356006dfe093f834f6072409b3 (patch)
treec1fd2324a63882dd34a6ddd3640fc372d4cef12f /python-jsonpath-ng/Makefile
parent0103e62bed6a118f9b8935c126790160fe55b02c (diff)
downloadopenwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.tar.gz
openwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.tar.bz2
openwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.zip
Add packages I am pussing to upstream
Diffstat (limited to 'python-jsonpath-ng/Makefile')
-rw-r--r--python-jsonpath-ng/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/python-jsonpath-ng/Makefile b/python-jsonpath-ng/Makefile
new file mode 100644
index 0000000..985c46c
--- /dev/null
+++ b/python-jsonpath-ng/Makefile
@@ -0,0 +1,31 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-jsonpath-ng
+PKG_VERSION:=1.4.3
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/j/jsonpath-ng/
+PKG_SOURCE:=jsonpath-ng-$(PKG_VERSION).tar.gz
+PKG_HASH:=b1fc75b877e9b2f46845a455fbdcfb0f0d9c727c45c19a745d02db620a9ef0be
+PKG_BUILD_DIR:=$(BUILD_DIR)/jsonpath-ng-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-jsonpath-ng
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ URL:=https://github.com/h2non/jsonpath-ng
+ TITLE:=python3-jsonpath-ng
+ DEPENDS:=+python3-ply +python3-six +python3-decorator
+ VARIANT:=python3
+endef
+
+$(eval $(call Py3Package,python3-jsonpath-ng))
+$(eval $(call BuildPackage,python3-jsonpath-ng))
+$(eval $(call BuildPackage,python3-jsonpath-ng-src))