summaryrefslogtreecommitdiff
path: root/python-humanize
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-02-15 13:29:19 +0100
committerKarel Kočí <cynerd@email.cz>2022-02-15 13:29:19 +0100
commitadf136e41c30971c523088ea71b46f11a616939d (patch)
treea17882162f09a2aa6ee97e9b83911f2394514739 /python-humanize
parent0ed3e2856a5700363e72c9bdfc993d453d409764 (diff)
downloadopenwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.tar.gz
openwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.tar.bz2
openwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.zip
healthcheck: add to test the development version
Diffstat (limited to 'python-humanize')
-rw-r--r--python-humanize/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/python-humanize/Makefile b/python-humanize/Makefile
new file mode 100644
index 0000000..6c08041
--- /dev/null
+++ b/python-humanize/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-humanize
+PKG_VERSION:=3.13.1
+PKG_RELEASE:=1
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=humanize
+PKG_HASH:=12f113f2e369dac7f35d3823f49262934f4a22a53a6d3d4c86b736f50db88c7b
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-humanize
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Python humanize utilities
+ URL:=https://github.com/jmoiron/humanize
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-periphery/description
+ This modest package contains various common humanization utilities, like
+ turning a number into a fuzzy human-readable duration ("3 minutes ago") or into
+ a human-readable size or throughput.
+endef
+
+$(eval $(call Py3Package,python3-humanize))
+$(eval $(call BuildPackage,python3-humanize))
+$(eval $(call BuildPackage,python3-humanize-src))